[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: secure_getenv is broken on FreeBSD.

From: Mats Erik Andersson
Subject: Re: secure_getenv is broken on FreeBSD.
Date: Thu, 7 Feb 2013 23:28:57 +0100
User-agent: Mutt/1.5.18 (2008-05-17)

onsdag den  6 februari 2013 klockan 22:31 skrev Paul Eggert detta:
> On 02/06/2013 05:10 PM, Mats Erik Andersson wrote:
> > Does not suffice! Same error as before
> I assume you tried it by hand?

Yes. Checking the sequence once more:

  * Inetutils with gnulib-7517e2 builds on FreeBSD-9.0
    since "secure_getopt" is not used.

  * Inetutils with gnulib-f65962 is broken on FreeBSD-9.0
    since "tempname" is making "secure_getenv" mandatory,
    against my will!

  * Cherrypicking the __need_getopt fix, removes the error

      ./getopt.h:199: error: redefinition of 'struct option'.

    However, the two more serious errors

      In file included from ./stdlib.h:96,
                       from secure_getenv.c:18:
      ./unistd.h:548: error: expected '=', ',', ';', 'asm' or
              '__attribute__' before 'extern'
      ./stdlib.h:607: error: expected '=', ',', ';', 'asm' or
              '__attribute__' before 'extern'

    which appeared with gnulib-f65962 are still present,
    and they prevent any progress.

> > a sed-scissor reveals
> > that "lib/unistd.h" and "lib/stdlib.h" both stumble into problems
> > when evaluating _GL_CXXALIAS_SYS.
> That sounds like a different issue, which would presumably neeed
> a different patch.

Question: How do I test whether _GL_CXXALIAS_SYS is intelligibly
expanded? The build system stands in my way, making the preprocessed
intermediaries inaccessible. The two abortive errors are pointing
in this direction, though.

  Mats Erik Andersson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]