[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

FYI: announcement-related typo in maint.mk

From: Jim Meyering
Subject: FYI: announcement-related typo in maint.mk
Date: Mon, 25 Mar 2013 05:34:02 +0100

I noticed that the generated announcement for diffutils-3.3
lacked the usual Cc: bug-diffutils.

Tracked it down to a bug in maint.mk.
I'll make the following into a commit pretty soon.
The alternative is to rename announcement_Cc_ to announcement_mail_Cc_,
but that would require all users (e.g., diffutils/cfg.mk) to rename,
too, so not a welcome change.  Besides, IMHO, the added "_mail" part
of the name does not improve readability.

diff --git a/top/maint.mk b/top/maint.mk
index 2b454a1..3f53d33 100644
--- a/top/maint.mk
+++ b/top/maint.mk
@@ -1308,10 +1308,10 @@ announcement_mail_headers_alpha =               \
   To: $(PACKAGE_BUGREPORT)                     \
   Cc: $(announcement_Cc_)

-announcement_mail_Cc_beta = $(announcement_mail_Cc_alpha)
+announcement_Cc_beta = $(announcement_Cc_alpha)
 announcement_mail_headers_beta = $(announcement_mail_headers_alpha)

-announcement_mail_Cc_ ?= $(announcement_mail_Cc_$(release-type))
+announcement_Cc_ ?= $(announcement_Cc_$(release-type))
 announcement_mail_headers_ ?= $(announcement_mail_headers_$(release-type))
 announcement: NEWS ChangeLog $(rel-files)
 # Not $(AM_V_GEN) since the output of this command serves as

reply via email to

[Prev in Thread] Current Thread [Next in Thread]