[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: m4-1.4.17 test-mbrtowc3.sh fails on Solaris without European localiz

From: Kiyoshi KANAZAWA
Subject: Re: m4-1.4.17 test-mbrtowc3.sh fails on Solaris without European localization
Date: Fri, 7 Nov 2014 18:24:54 +0900 (JST)


If you know which test depends on which locale,
the best way is to check the locale is installed or not.

For example, test suite of diffutils-3.3, findutils-4.4.2 and grep-2.20 says:
"Skipping test: no traditional french locale is installed"
"Skipping test: no french Unicode locale is installed" .

I do not know how they do it, but it can be a help.
As far as I tried,
% pkginfo | grep -i localization
can be used on Solaris.

Another idea is leave the test as it is, but print a message like
"This test depends on French locale.
 You can ignore the error if you do not installed it."

# I usually install all the European localizations adding to Japanese,
# but tried to shrink OS partition and found this.
# (Hablo espan~ol, tambien,  und Ich sprach ein bisschen Deutsch.)


--- Kiyoshi

----- Original Message -----
From: Daiki Ueno <address@hidden>

Eric Blake <address@hidden> writes:

> [adding gnulib]
> On 11/06/2014 11:19 AM, Kiyoshi KANAZAWA wrote:
>> Hello,
>> On Solaris 10 x86/x64,
>> "test-mbrtowc3.sh" fails if European localization is not installed.
>> It passes with European localization.

I can reproduce it, and it seems to be the same issue as:
which I originally encountered on Solaris 11.
(It's curious that you could work it around by installing European
localization, while the test checks the mbrtowc behavior under Japanese

Perhaps it would be good to replace mbrtowc on Solaris, though I have no
idea how to detect the wrong behavior without depending on particular
locale data.  Alternatively, we could simply ignore this test failure on
Solaris, since the tested calling convention is not very common.


Daiki Ueno

reply via email to

[Prev in Thread] Current Thread [Next in Thread]