[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "test-lock" stuck on FreeBSD

From: Daiki Ueno
Subject: Re: "test-lock" stuck on FreeBSD
Date: Thu, 04 Dec 2014 12:53:14 +0900
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.0.50 (gnu/linux)

Thanks for looking into it.

Ed Maste <address@hidden> writes:

> On 17 November 2014 at 05:34, Daiki Ueno <address@hidden> wrote:
>> As I'm getting more reports (perhaps) related to this, I've filed a bug
>> at the FreeBSD bugzilla, with a reproducer written in plain pthreads:
>> https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=195098
> To clarify, does this issue seem to occur randomly on some runs,
> without changing anything?11

Yes.  I compiled it with:

  $ cc -o test-once test-once-pthread.c -lpthread

If it ran ok, it took ~13 sec:

  $ time ./test-once >/dev/null
         13.01 real         4.10 user         8.90 sys

Otherwise, I had to interrupt the process by ^C:

  $ time ./test-once >/dev/null
  ^Ctime: command terminated abnormally
        288.40 real        67.36 user       220.85 sys

> I've tried your reproduction code on my FreeBSD laptop and have not
> been able to reproduce the failure; it runs in ~4 seconds each time.

Actually, I haven't tried it on a bare metal, but on Assaf's freebsd10
build-ready VM image:


running under kvm on GNU/Linux with the following command line:

  $ qemu-kvm -nographic -m 384 \
      -snapshot \
      -net user -net nic,model=virtio \
      -drive if=virtio,media=disk,index=0,file=freebsd10.build-ready.qcow2

Daiki Ueno

reply via email to

[Prev in Thread] Current Thread [Next in Thread]