[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gettext problems

From: Bruce Korb
Subject: Re: gettext problems
Date: Sun, 07 Dec 2014 17:49:55 -0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.2.0

On 12/06/14 15:05, Daiki Ueno wrote:
Looking at sharutils/bootstrap, it invokes autopoint before gnulib-tool
--import, and then pulls the 'gettext' module from Gnulib.  That means
intl.m4 and po.m4 will be replaced with Gnulib's version.

I tried the attached patch and it seems to work.

Yes, it does.  Thank you.

> So I have two questions: why do you need 'gettext' module from Gnulib
> and why do you run autopoint before gnulib-tool --import?

Somewhere along the line my toe was stubbed and running autopoint
seemed to be indicated.  I tried it, things got better and I had
no reason to go back, until my toe was stubbed again. :)
Since gnulib advertises itself as having the most up-to-the-second
gettext, it seemed mighty odd that my installed version had a
more recent version number than that of gnulib.  Oh, well, your
patch worked just fine.  I now use my installed gettext and it
is likely to be sufficiently up-to-date for my needs.

Thank you!

Regards, Bruce

reply via email to

[Prev in Thread] Current Thread [Next in Thread]