[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

SED not being declared in Makefile

From: J William Piggott
Subject: SED not being declared in Makefile
Date: Mon, 16 Jan 2017 20:13:53 -0500

Hello all, I am not subscribed so please cc me.

>From my local gnulib git repo when I run:
 ./gnulib-tool --create-testdir --dir=/tmp/test3 parse-datetime

It fails with:
/bin/sh ../build-aux/ylwrap ./parse-datetime.y \
                              y.tab.c parse-datetime.c \
                              y.tab.h parse-datetime.h \
                              y.output parse-datetime.output \
                              -- bison -y   && \
 's|".*/parse-datetime.y"|"parse-datetime.y"|' \
 < parse-datetime.c > parse-datetime.c-t && \
mv parse-datetime.c-t ./parse-datetime.c
/bin/sh: line 6: s|".*/parse-datetime.y"|"parse-datetime.y"|: No such file or 
make: *** [parse-datetime.c] Error 127


Because SED is not being declared. All is well if I run it like this:
 SED=/usr/bin/sed ./gnulib-tool --create-testdir --dir=/tmp/test3 parse-datetime

It seems to be caused by this recent commit:

commit 73ecb533f82b613245451f05d12726a41ceca95d
Author: Pádraig Brady <address@hidden>
Date:   Tue Jan 3 00:52:13 2017 +0000

    parse-datetime: fix generated paths for coverage files

 8< ---

-       mv parse-datetime.c parse-datetime.c-t && \
+       $(SED) 's|".*/parse-datetime.y"|"parse-datetime.y"|' \
+        < parse-datetime.c > parse-datetime.c-t && \

 8< ---

Doesn't the AC_PROG_SED macro have to be called somewhere to set SED?
I don't see it.

Or, perhaps it should just be sed instead of $(SED)? That is the only
place in the Makefile that $(SED) is used.

Thank you

reply via email to

[Prev in Thread] Current Thread [Next in Thread]