[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Tim Rühsen
Subject: gnulib-tool.py
Date: Mon, 04 Sep 2017 21:29:28 +0200
User-agent: KMail/5.2.3 (Linux/4.12.0-1-amd64; KDE/5.28.0; x86_64; ; )


just tried out gnulib-tool, taking the very naive approach:

- (in gnulib/) git checkout pygnulib
- made a commit with this change
- edited project's bootstrap to rename gnulib-tool into gnulib-tool.py
- tried './bootstrap'.

./bootstrap: 920: ./bootstrap: gnulib/gnulib-tool.py: Permission denied

This is easily fixed by 'chmod a+x gnulib/gnulib-tool.py'

Second try resulted in:
./bootstrap: gnulib/gnulib-tool.py  --import --no-changelog --aux-dir build-
aux --doc-base doc --lib libgnu --m4-base m4/ --source-base lib/ --tests-base 
tests --local-dir gl --makefile-name=gnulib.mk --libtool --import ...
usage: gnulib-tool.py --help
gnulib/gnulib-tool.py: error: argument -i/--import: expected at least one 
Traceback (most recent call last):
  File "gnulib/gnulib-tool.py", line 927, in <module>
    errno = error.errno
AttributeError: 'exceptions.SystemExit' object has no attribute 'errno'
./bootstrap: gnulib-tool failed

Maybe I did something basically wrong !?

Attached bootstrap.conf

Attachment: bootstrap.conf
Description: Text document

Attachment: signature.asc
Description: This is a digitally signed message part.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]