[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [platform-testers] new snapshot available: sed-4.4.104-290c

From: Paul Eggert
Subject: Re: [platform-testers] new snapshot available: sed-4.4.104-290c
Date: Fri, 30 Mar 2018 09:18:25 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.6.0

On 03/30/2018 07:20 AM, Nelson H. F. Beebe wrote:
I just looked up that standard (page 37) and tried its several
examples with /bin/sh on Solaris 10.  To my surprise, some of them
produced errors, and not the output shown in those examples.

I then repeated the experiment with /usr/xpg4/bin/sh, and they
worked as shown in POSIX.

Yes, and this is why scripts like 'configure' automatically reexecute themselves with bash or ksh or whatever, if they find themselves running on Solaris 10 /bin/sh. Although it's a bit awkward, it's better than trying to live within the intersection of the old SunOS sh and a POSIX shell. In 'sed' you found one script that wasn't doing that, but Jim has fixed that now (by removing the script!).

I just now checked and ./configure still tries sh5, an Ultrix-based POSIXish shell that was last released in 1995! We have the late Fred Canter to thank for that, I imagine. See:

Hall J. The last farkle. Linux J. 2007-12-02. https://www.linuxjournal.com/node/1005779

reply via email to

[Prev in Thread] Current Thread [Next in Thread]