[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

minimum supported Autoconf and Automake versions

From: Bruno Haible
Subject: minimum supported Autoconf and Automake versions
Date: Fri, 19 Oct 2018 03:22:40 +0200
User-agent: KMail/5.1.3 (Linux/4.4.0-137-generic; KDE/5.18.0; x86_64; ; )


In a couple of places, we have code to cater with old versions of
Autoconf or Automake. Such as this one:

  # Remove this macro when we can assume autoconf >= 2.62 or
  # autoconf >= 2.60 && automake >= 1.10.

Which version can be assumed nowadays? I think one can determine this
by looking at the oldest version that is the default in a Linux distro.
The Linux distro which regularly ships the oldest version of any
package is RHEL or its clone CentOS. So that's what we need to look at.
According to [1], RHEL 5 and CentOS 5 are unsupported since 2017.
RHEL 6 and CentOS 6, then, ship with autoconf 2.63 (released in 2008)
and automake 1.11.1 (released in 2009) [2].

I would therefore propose to assume autoconf >= 2.63 and automake >= 1.11.

The list of versions available on current-day Linux distros [3][4]
does not show a problem.

This proposal goes a bit further than my earlier guesswork in January 2017


[1] https://en.wikipedia.org/wiki/CentOS#End-of-support_schedule
[2] http://mirror.centos.org/centos/6/os/x86_64/Packages/
[3] https://repology.org/metapackage/autoconf/versions
[4] https://repology.org/metapackage/automake/versions
[5] https://lists.gnu.org/archive/html/bug-gnulib/2017-01/msg00102.html

reply via email to

[Prev in Thread] Current Thread [Next in Thread]