[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Simon Josefsson
Date: Tue, 23 Nov 2021 21:02:09 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.1 (gnu/linux)

Hi.  This may mostly be for Bruno, but I believe it is more relevent to
gnulib than gettext, even though it is gettext-related, and maybe others
on this list can provide feedback too.

I got a bug report that suggested using AM_GNU_GETTEXT_REQUIRE_VERSION:


The suggestion boils down to:


Libidn2 (and many other packages) contains:


Reading gettext NEWS suggests to me that 0.19.8 fixed something for
musl, and that this gettext fix is what is needed to build packages
using gettext on that platform.  Am I understanding correct?

If so, my usage of AM_GNU_GETTEXT_VERSION([0.19.3]) seems indeed
problematic because it leads to a too old gettext infrastructure being
pulled in.  It would be nice if my package used the latest available
gettext files during bootstrapping, so I should use this:


Then assuming the person rebootstrapping libidn2 using a sufficiently
modern gettext (>=0.19.8) will get the acceptable fixes for musl.

Before fixing this, it occured to me that this seems like something that
should be generally true for any project using gettext.  Thoughts?  Why
wouldn't you want gettext to use the latest available infrastructure
files?  The situation seems similar to libtool's M4 handling.

Thus I would prefer to write a 'make syntax-check' rule to catch this,
and suggest that all packages should use AM_GNU_GETTEXT_REQUIRE_VERSION
to get latest gettext files included in them.  Thoughts?


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]