[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

libtextstyle-optional fails ./gnulib-tool --test

From: Paul Eggert
Subject: libtextstyle-optional fails ./gnulib-tool --test
Date: Fri, 24 Dec 2021 17:37:50 -0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.3.1

The command "./gnulib-tool --test libtextstyle-optional" fails with the last few output lines as follows. I tried going back into the past but didn't find an old Gnulib version where the command worked (though the failure symptoms differed), so I don't think this is purely due to recent Gnulib changes.

gcc -DHAVE_CONFIG_H -I. -I../../gltests -DGNULIB_STRICT_CHECKING=1 -I. -I../../gltests -I.. -I../../gltests/.. -I../gllib -I../../gltests/../gllib -DSRCDIR=\"../../gltests/\"   -Wno-error -g -O2 -MT test_libtextstyle-test-libtextstyle.o -MD -MP -MF .deps/test_libtextstyle-test-libtextstyle.Tpo -c -o test_libtextstyle-test-libtextstyle.o `test -f 'test-libtextstyle.c' || echo '../../gltests/'`test-libtextstyle.c ../../gltests/test-libtextstyle.c:20:10: fatal error: textstyle.h: No such file or directory
   20 | #include <textstyle.h>
      |          ^~~~~~~~~~~~~
compilation terminated.
make[4]: *** [Makefile:2239: test_libtextstyle-test-libtextstyle.o] Error 1
make[4]: Leaving directory '/home/eggert/src/gnu/gnulib-tmp/testdir1900592/build/gltests'
make[3]: *** [Makefile:2259: all-recursive] Error 1

reply via email to

[Prev in Thread] Current Thread [Next in Thread]