[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bug#32452: 26.1; gnutls_try_handshake maxes out cpu retrying when se

From: Paul Eggert
Subject: Re: bug#32452: 26.1; gnutls_try_handshake maxes out cpu retrying when server is a bit busy
Date: Tue, 1 Mar 2022 17:00:36 -0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.5.0

On 3/1/22 10:52, Lars Ingebrigtsen wrote:
Paul Eggert<eggert@cs.ucla.edu>  writes:

I looked into the problem some more and found what I think is the
underlying problem: gnulib-tool generated lib/gnulib.mk.in before it
generates m4/gnulib-comp.m4, which Makefile-generation relies upon. I
reverted my recent hack to emacs/admin/merge-gnulib and installed the
attached Gnulib patch. Please update to the latest Emacs and Gnulib
and try again.
I tried this now, but the symptoms seem to be the same -- after trying
to use nanosleep, as described before, I still get:

/usr/bin/ld: gnutls.o: in function `gnutls_try_handshake':
/home/larsi/src/emacs/gtest/src/gnutls.c:634: undefined reference to 
collect2: error: ld returned 1 exit status

Do you see this problem with a fresh checkout from the latest master branch, combined with the latest Gnulib? If not, problem solved. If so, what's the output of 'git status' and of 'git diff' when things fail?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]