[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Initrd diskless netboot problems

From: Michael Sullivan
Subject: Initrd diskless netboot problems
Date: Mon, 9 Oct 2000 01:10:38 -0400

Hello -

Grub version: 0.5.96
Configured with ./configure --enable-eepro100 --enable-diskless
Machine has *NO* disks, EEPro100, 128M RAM.  That's about it, very

I'm using PXE to load pxegrub.  This works fine.

I have a Linux kernel 2.2.16 with ramdisk, networking, and very little
else installed in it.  Additionally, I have created a disk image for a
minimal root filesystem

I prepared the kernel using rdev as follows:

rdev -R vmlinuz.rd 0
rdev vmlinuz.rd /dev/initrd

The major and minors for initrd are 1,250.  This is from the kernel
header files.  it was created using:

mknod /dev/initrd b 1 250

I've also tried setting the root device with rdev to /dev/ram (1,1),
/dev/ram0 (1,0) and /dev/ramdisk (symlink to /dev/ram0).

GRUB loads everything fine - both the kernel and the image file.  I did
have to modify asm.S to make the string "/boot/grub/menu.lst" to
"/tftpboot/grub/menu.lst".  That seemed to make everything load

Took me a while to figure out that the "title" command was required by

>>>>>>>>>>>>>>>>>> menu.lst <<<<<<<<<<<<<<<<<<<
timeout 0
title Ramdisk Linux
kernel /tftpboot/vmlinuz.rd
initrd /tftpboot/initrd.imz

When I run the commands manually, I get the following:

GRUB version 0.5.96  (640K lower / 129984K upper memory)

[Address information ommitted...]

grub> kernel /tftpboot/vmlinuz.rd
   [Linux-bzImage, setup=0x800, size=0x5a030]

grub> initrd /tftpboot/initrd.imz
   [Linux-initrd @ 0x7e78000, 0x177000 bytes]

grub> boot

[All the usual linux boot messages...  until...]
VFS: Cannot open root device 01:fa
Kernel panic; VFS: Unable to mount root fs on 01:fa

I'm quite at a loss as to where to proceed at this point.  I've been
hacking on this in varying combinations of device major and minors, but
to no avail.

One note, all devices attempted are in the dev directory of the rootfs

Any help would be appreciated.  I'm willing to experiment.  The machine
I'm using is *completely* diskless.  Any other information nedded, just
ask.  I'm trying to use this machine without using NFS, but just a
minimal installation of linux for some embedded systems work.



Michael P. Sullivan                                  
Distributed Computing Systems, LLC                         Cell: 516-429-2080 
E-Mail: address@hidden                           http://www.discomsys.com/ 
    * UNIX Systems and Database Consulting, Architecture and Management *
"The two most common elements in the universe are hydrogen... and stupidity."
                                   Harlan Ellison

reply via email to

[Prev in Thread] Current Thread [Next in Thread]