[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Trouble compiling GRUB

From: OKUJI Yoshinori
Subject: Re: Trouble compiling GRUB
Date: Sat, 25 Nov 2000 10:40:50 +0900

From: Farid Hajji <address@hidden>
Subject: Trouble compiling GRUB
Date: Sat, 25 Nov 2000 02:00:10 +0100

> What's going on? I was able to compile an earlier version of grub
> (grub-0.5.96 from CVS) without problems.

  Perhaps that is due to a bug in your gcc. In gcc-2.7.x, the option
"-B" (and also "-v") worked just fine, but gcc-2.95.x seems not to
work. A workaround could be to install gcc as well as binutils into a
private directory. *sigh*

> # O_SYNC in grub/asmstub.c not recognized on my system.
> # removed O_SYNC flag in line 1032 of grub/asmstub.c.
> # this worked with grub 0.5.96

  Please report any bug! I haven't ever heard this. Doesn't FreeBSD
support O_SYNC? I thought it should have, because O_SYNC is defined in
POSIX. In FreeBSD, how to ensure that I/O operations are synchronous?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]