[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Marco Pfatschbacher
Subject: SCSI-Problems
Date: Sun, 10 Dec 2000 14:27:49 +0100


my System:

a 4,5 GB SCSI disk on an Adaptec 2940, 
a 20 GB and a 46 GB IDE-Disk.

$ fdisk -l  /dev/sda

Festplatte /dev/sda: 255 Köpfe, 63 Sektoren, 555 Zylinder
Einheiten: Zylinder mit 16065 * 512 Bytes

    Gerät boot.  Anfang      Ende    Blöcke   Id  Dateisystemtyp
/dev/sda1            11       202   1542240    5  Erweiterte
/dev/sda2             1        10     80293+  16  Verst. FAT16
/dev/sda3   *       203       456   2040255    b  Win95 FAT32
/dev/sda4           457       555    795217+  16  Verst. FAT16
/dev/sda5            11       195   1485981   83  Linux
/dev/sda6           196       202     56196   82  Linux Swap

I put Grub 0.5.96 with a:
$ cat stage1 stage2 > /dev/fd0   to a floppy.

Please note that all disks are set in BIOS, so GRUB detects 3 disks.

To avoid grub to hangup I had to disable the Int-13-Extensions on my 2940.
I've tried to boot up W2K which is on the SCSI-Disk. (sda3):

map (hd0) (hd2)  
map (hd2) (hd0)
chainloader (hd2,2)+1

after "boot" grub hangs up whithout any message.

But after unsetting my 2 IDE-disks in BIOS the following worked fine:

chainloader (hd0,2)+1

Are there known Problems with mapping SCSI-Disks, or allows the
map command only to swap 0x80 and 0x81 ?

Booting my Linux-2.2.17 Kernel works fine, except one Problem:

It seems there are no/wrong parameters passed to the kernel.

"kernel (hd2,4)/boot/2217/vmlinuz"
works, but with:
"kernel (hd2,4)/boot/2217/vmlinuz root=/dev/sda5"

Linux tries to mount its root on 0:00.


Marco Pfatschbacher

 \ /
  X  ASCII Ribbon campaign against HTML E-Mail
 / \

reply via email to

[Prev in Thread] Current Thread [Next in Thread]