[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bug - SCSI and IDE drives

From: James Magnusson
Subject: Bug - SCSI and IDE drives
Date: Fri, 29 Dec 2000 00:47:18 -0600

I just installed Caldera eDesktop 2.4 on to a dual processor machine at
home. And it took two days to figure out why Grub wouldn't boot linux.
It would just give me its command prompt. The reason it was doing this
was because I had the BIOS set to boot off of SCSI frist. And this was
confusing it. For whatever reason once linux starts up it assigns the
IDE drive as (hd0) and the SCSI drive as (hd1), but the system was set
to boot the SCSI drive first making it (hd0) and the IDE (hd1). I ended
up have to go into my BIOS and change the boot order to boot off of the
1st IDE drive fist. And then install Grub to the MBR to get it to load
    I tried to reconfigure Grub so that it would be able to find the
boot partion on start up, but when I tried to reinstall it would
complain that it didn't exist. Of course if  I let it the way it was and
restarted it would still complain that it didn't exist. I checked by
using the root command and booting off of the SCSI drive root was
(hd0,0) not (hd1,0) like in the confige file. The first partion on the
SCSI drive is the / dir of linux and the fist partion on the IDE was
empty (it now has WinNT 4.0)

    On windows NT 4.0 Grub wouldn't boot it if it was an NTFS partion.
but when I reinstalled NT as a FAT partion it worked fine.

Now that I finally  have Grub working I like it. But formating a 2GB
partion in FAT wastes space.

BTW - It's an Tyan S1696DLUA w/ Intel 82371AB (PIIX4) and Adaptec 7895
ultra-wide controller on board, (2) PII 333Mhz, 256MB Ram, the IDE drive
is a Maxtor 90843D4, the SCSI drive is a Seagate ST1910W. The version of
Grub is 0.5.94


reply via email to

[Prev in Thread] Current Thread [Next in Thread]