[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub exits with no error message

From: Steff and Eric Runquist
Subject: Grub exits with no error message
Date: Mon, 23 Sep 2002 22:23:52 -0400
User-agent: KMail/1.4.2

Hi guys,

I'm having trouble using GRUB 0.90 to boot a PC I'm installing Gentoo Linux

Gentoo Linux 1.2
GRUB 0.90
Sony Vaio PC
Intel 200 Mhz Pentium processor
4 GB hard disk
GRUB installed to the hard disk's MBR

When I boot the machine I get the menu, just like I set it up in menu.lst,
but when I select the OS and press Enter, the PC reboots. There is no
error message that I can see.

I went through the installation instructions for Gentoo Linux, which
includes setting up GRUB. Gentoo came with GRUB 0.90. I followed
these steps to setup GRUB (after setting up the partitions, kernel, etc.):

I ran grub, then typed the following:

    grub> root (hd0,0)
    grub> setup (hd0)
    grub> quit

Next, I put the following in my menu.lst file:
    default 0
    timeout 30

    title=My example Gentoo Linux
    root (hd0,0) 
    kernel /boot/bzImage root=/dev/hda3 

I've tried booting from the Gentoo install CD, then
running grub and entering the following:

    grub> root (hd0,0)
    grub> kernel /boot/bzImage root=/dev/hda3 
    grub> boot

After I press enter, I'm dumped back to the bash shell I
ran GRUB from. There is no error message. I've tried the
same thing, except with the --verbose flag and that also
provides no messages.

I read through the GRUB tutorial on IBM's Developer Works
site, and read through the FAQ's for both Gentoo and GRUB.

I don't know what else to try.

Thanks for any help you can give me!
Eric Runquist

reply via email to

[Prev in Thread] Current Thread [Next in Thread]