[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Weird menu.lst behaviour.

From: Yann Golanski
Subject: Weird menu.lst behaviour.
Date: Wed, 5 Feb 2003 15:33:46 +0000
User-agent: Mutt/1.5.3i

I have a system with two disks: FreeBSd on hd1 and Win2k on hd0.  The
BIOS is currently set up so that it boots from floppy, then hd1 then
hd0.  I have install grup from the FreeBSD-5.0 port which gave me
version 0.92.  I have created a floppy and have been using that to boot
my machine and have installed (via setup) the bootloader using "root
(hd1,a)" then "setup (hd1)" which reported to have worked fine.

Now, if I use the floopy, I can boot both FreeBSD and Win2k using:
  root (hd1,a)
  kernel /boot/loader
  root (hd0,0)
  chainloader +1
It works no problem.  So, I tried to load a configuration file as below:
-----cut here.
        # Sample boot menu configuration file
        default 0
        timeout 13
        fallback 1
        color cyan/blue cyan/black
        title Rivendel aka FreeBSD
        root (hd1,a)
        kernel /boot/loader
        title Lorien aka Win2k
        root (hd0,0)
        chainloader +1
-----cut here.
This works fine when I am booting the loader from floppy. 

However, it all goes pear shape as soon as I try to use the installation
that I have done on (hd1).  

The Window options just droped me back into the boot loader and the
FreeBSD one crashes with "root (hd1,a) error 22: No such partition".

Do you have any idea what is happening there?

address@hidden                  -=*=-                      www.kierun.org
    PGP:   009D 7287 C4A7 FD4F 1680  06E4 F751 7006 9DE2 6318
    IRC:   nick kierun, server spod.uk.amiganet.org, channel #sanctus
    NNGS:  nick kierun, server nngs.cosmic.org, port 9696.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]