[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Booting of FAT partition problem

From: Spiro Philopoulos
Subject: Booting of FAT partition problem
Date: Thu, 06 Feb 2003 22:15:39 -0600

I'm new to GRUB and I'm using it to boot Linux (LRP) off a FAT16 partition
(100MB in size, located in the first cylinders of the disk). I install GRUB
succesfully using the floppy method (root (hd0,0) and setup (hd0) with
/dev/hda1 being the FAT16 partition). On bootup everything goes well until the
system tries to load the initrd image to ramdisk, at which point I get a kernel
panic proceeded by some DOS jibberish. The odd thing is that the first time I
tried it worked, but later on when I repartitioned my drive and started all
over I get this problem even though I used the same partition scheme. One thing
to note is that when I try the install GRUB from floppy, it fails to find (the
optional?) fat_stage1_5 even though it's located in /boot/grub/ on the FAT
partition, because the file name is cut-off after the eigth character (is there
a way around this BTW?). Any help/info would be greatly appreciated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]