[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

grub/multiple os's

From: morley weitzman
Subject: grub/multiple os's
Date: Tue, 25 Feb 2003 21:50:37 -0800 (PST)

i've got a series of complicated problems and unable to resolve them....i've been at your website "http://www.gnu.org/software/grub/#contact" and followed all suggestions but cannot solve or see answers to the problems...

here's a description of the hardware i have and what OSs I have installed...i have a master/20gb-seagate harddrive(A) configured as follows: partition#1) OS-x95 in the first 2gbs w bootmagic for my bootloader; partition#2) OS-XP remainder 17gb's.....i have a 2cnd slave/60gb-westerndigital harddrive(B) for backup configured as follows prior to installing redhat8.0: partition#1) OS-x95 in the first 2gbs w bootmagic for my bootloader; partition#2) 21gb's unallocated for linux installation; partition#3) OS-XP remainder 34gb's.

i installed redhat8.0 into the second partition on the western digital slave, "the works" successfully into hd(B)partition#2) as a single drive installation, and could initially successfully boot up into either redhat or XP on hdB, but never to x95...


q#1)...i've attempted to edit grub while booting up to enable me to boot into x95...the furthest i got was GRUB booted me into a system shell where the following text comes up... "Open Windows 95....."Type the name of the Command Interpreter (e.g.,C:\Windows\command.com) (...new line...) A>_          ". I presume GRUB is working but Bootmagic and/or x95 can't be loaded, because I do not have access to or the name of the Command Interpreter. What do I need to do to get GRUB to boot me into the x95 OS?? Should I uninstall Bootmagic in the x95 partition or is there a less destructive remedy?? I'd also like to configure GRUB to allow me to boot into x95 or XP on the seagate drive if I use the seagate as the slave and the western digital as the master. I've tried to interactively configure grub when I boot up to get me into either OS on the seagate drive but I haven't been able to do it. How can I do it??


q#2)....I was initially able to make either the x95 or XP partition active on the westerndigital drive using partition magic7.0 from the seagate...if x95 was active when I booted up w GRUB and I attempted to boot into XP, the XP os begins to boot as the black MS timer screen comes up but the welcome blue screen never loads ...instead I get a darker blue DOS screen with a "fatal error message stating that the Initialization System process terminated unexpectedly.....the system has been shut down"...I initially was able to fix the problem by setting the westerndigital XP partition ACTIVE via the seagate XP partition by using partition magic. That worked and I attempted to resolve my other problem of using GRUB to boot into any OS on either drives. As I mentioned I tried a number of possibilities but none worked. Instead now, no matter what I try, I cannot set the westerndigital XP partition ACTIVE via partionmagic from the seagate, and now when I attempt to boot into XP using GRUB, i always get the fatal error message described above. I'm assuming the remedy to get GRUB to boot me into XP is to make XP active, prior to booting, since that worked previously. How can I get grub to let go and allow me to set XP active?? Or better yet, what can I do short of a redhat/GRUB/reinstallation or deleting the westerndigital XP partition and then copying the seagate XP partition back to the westerndigitial, to get GRUB to allow me to boot to XP too??? Am I making things too complicated or is there an easier way??. I'm presuming the problem is that i am using 2 bootloaders and GRUB is too aggressive.

By the way, I never used linux before monday/yesterday when i installed redhat8 and the reason I installed x95 was because i write scientific programming code (3D finite element solutions to partial differential equations like heat flow and groundwater flow) using a lahey fortran compiler and I have a load of executables that will not run on XP/NTFS but will run on a fat16/32 platform. Thats another reason why i wanted to try linux...for the f77 compiler/library...etc.



Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, and more
reply via email to

[Prev in Thread] Current Thread [Next in Thread]