[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: kernel panic

From: mi
Subject: Re: kernel panic
Date: Thu, 20 Mar 2003 02:55:04 +0100

Hello again.
Before anybody answer my first mail, please rerad this.
The bootfloppy basically is working.
When i boot a 2.4.17 kernel ( no matter if from the harddrive or from the 
floppy) it comes up ok, but then freezes, after 'Mounted root (ext2) readonly'
.... only occasionally with some error reporting (see below).
The root filesystem is on ide1 (master) = (hd1,5) = hdc6, a logical partition 
about 17 GB  'far' from the rim. I don't use any 'lba' option for grub.
i did some tracking...
My first idea was to pass the --no-mem-option; but that did not match....
Next idea, swap: there's a swap on each of both drives;
so the kernel has to access the a ide drive that was inactive before.
That's a difference i can imagine to my current 'fixed' LILO configuration, 
that chains from ide0 to ide1.
But excluding the ide0-swap from /etc/fstab won't match, either.
No i tried to boot a 2.2.19 kernel from ide0.
That worked !
Next i copied this kernel to ide1, and voila ! there it works, too.
Also from floppy.
So it seems to be a 2.4.17 specific problem.

Here's the first lines of it's error output, that occurs not every time, so 
I'm not sure if this is related to the freezing or not:

Unable to handle paging request at virtual address f604c487 
printing eip: c0118e3e
xpde: 000000000000
Oops: 0002
[ much more stuff below, but no human language words...]

How to go on ?
1) Let it go and stay with LILO.
But after trying the grub stage2-shell i never will be satisfied with lilo 
again ....
2 ) Stay with the old kernel ?
3) Try compile a more recent kernel 
4) Track and find some options / tuning for grub and the kernel as well
This i would prefer, because it's the safest to know what went wrong.

Since the failure doesn't occur with LILO, the question is: what is grub 
doing another way that affects the kernel between mounting the root and 
starting init.

What ideas do i have ?
a) Try to find out what the kernel message means. 
- probably i have to mail to some kernel.org and wait some more days....not 
funny. I don't know the right address where to ask, in addition :-|
b) Reading up loads of archive pages with my slow like hell dialup link :-|
c) Check something with mapping (lilo chains with 0x80 to 0x83)
d) that was all :-(

I was so hopeful that with grub i can get rid of most chainloading .....
If i the end have to chain the two mbr's as well here with grub, please let 
me know, so that i don't have to run through all test i can imagine....

Would be thankful for any little help.


# -------------- Here's the menu.lst:


title Woody 2.4.17  kernel (fd0)
root (fd0)
kernel (fd0)/boot/vmlinuz-2.4.17 root=/dev/hdc6

title Woody 2.4.17  kernel (hd1,0)
root (hd1,0)
kernel (hd1,0)/vmlinuz root=/dev/hdc6

# ----------- Here the relevant etc/fstab - Partitions:
1,5  || /dev/hdc6         /     ext2    auto,user,rw,exec,dev,suid
1,6  || /dev/hdc7        none   swap    sw,pri=1
1,0  || /dev/hdc1        /boot_1        ext2    auto,user,rw,exec,suid
0,2   || /dev/hda3  none        swap    sw,pri=2
0.1   || /dev/hda2  /boot_0 ext2    auto,user,rw,exec,suid

reply via email to

[Prev in Thread] Current Thread [Next in Thread]