[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [grub #64] modules smaller than 4k fail

From: Teemu Voipio
Subject: Re: [grub #64] modules smaller than 4k fail
Date: Mon, 31 Mar 2003 01:12:25 +0300
User-agent: Mutt/

On Mon, Mar 31, 2003 at 01:16:09AM +0900, Yoshinori K. Okuji wrote:
> Delivered-To: address@hidden
> Date: Mon, 31 Mar 2003 01:16:09 +0900
> From: "Yoshinori K. Okuji" <address@hidden>
> Subject: Re: [grub #64] modules smaller than 4k fail
> Reply-To: address@hidden
> To: BugCommunicator <address@hidden>
> At Sat, 29 Mar 2003 14:12:46 +0900,
> address@hidden wrote:
> > When a module is smaller than 4k (after uncompressing), GRUB says "file not 
> > found" even if the file is actually present. The gzipped version of the 
> > file can be smaller.
> I cannot reproduce your problem. Maybe it is a filesystem-specific
> problem. What filesystem are you using?

It was a VFAT floppy.

I tried to check if the size was really 4k that it failed for, and
noticed that it now works. My kernel size has changed since then though,
so it might be that it only happens if kernel is very small also ?

I have my kernel in RCS so I tried building the same kernel. No success.

What I can still say, is that the actual filesize never was of
importance. I tried compressing a module slightly less than 4k, and
didn't work, tried compressing a module slightly more than 4k, which
after compression was just few hundred bytes, and it did work.

What do we do with this one ? One possibility is to close the bug, and
I'll notify if I ever get this again (and save the floppy image this
time). It happened with both real floppy and image, with real hardware
and in Bochs.

 - Teemu Voipio <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]