[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Failure to boot into Linux

From: cr
Subject: Re: Failure to boot into Linux
Date: Fri, 10 Oct 2003 19:56:58 +1300

On Thu, 09 Oct 2003 06:35, Rolf B Johannesen wrote:
> Dear Sirs:
> I have a computer system with a 40 Gb hard drive.  30 Gb is partitioned
> for Windows XP and the rest is partitioned for Linux.  I regularly boot
> Linux from  a floppy, but I would like to get GRUB installed on the hard
> drive eventually.  As a start I have copied GRUB to a floppy.  I can boot
> into Windows successfully using the chainloader command.  But I cannot
> boot into Linux.  Below is the sequence of commands and responses that I
> get.  It is consistent.
> start by booting from floppy
> GRUB loading Stage 2
> GRUB version 0.92 (640K lower / 261056K upper memory)
> [Minimal BASH-like line editing is supported.  For the first word, TAB
> lists possible command completions.  Anywhere else TAB lists the possible
> completions of a device/filename]
> grub>root (hd0,4)
>         Filesystem type is ext2fs, partition type 0x83
> grub>kernel  /vmlinuz  root=/dev/hda5
>         Error 15: file not found
> The Linux /boot directory lists vmlinuz as a link, and it also lists 4
> other files beginning with vmlinu, then either x or z, followed by
> -2.14.18-4  I have tried all possible combinations on the 'kernel' line
> with no success.  I also tried
> kernel  /boot/vmlinuz  root=/dev/hda5
> When I boot from the Linux boot floppy, I get a message telling it is
> booting from /dev/hda5, so that is correct.  Please suggest what I am
> doing wrong.

As a possibility - you don't say how many partitions you have.   
I *think* Grub just counts 'actual' partitions.   Easiest shown 
by an example:

Linux name                     Grub name
/hda1         Windows       (hd0,0)
/hda2         Windows       (hd0,1)
/hda3         Extended        --
        /hda5    Linux         (hd0,2)
        /hda6    Linux         (hd0,3)
        /hda7    Linux         (hd0,4)

So your Grub command   root (hd0,4)  will show an
ext2 partition but it's looking at /hda7 not /hda5,
hence can't 'see' your vmlinuz on /hda5.
In the above example you'd need   root (hd0,2)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]