[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

switching between lilo and grub

From: Aaron P. Martinez
Subject: switching between lilo and grub
Date: 14 Oct 2003 14:25:43 -0500

I had a special case where i'm using ghost to clone some drives.  After
about 4 attempts, and every time when booting up the cloned drive i made
it to a 'grub' prompt that didn't do anything i called the person who
suggested it.

He informed me that ghost won't work with grub and to install lilo on
the original drive, clone it, boot the new cloned drive and then
reinstall grub. 

All went well until i tried to switch back to grub.  He had originally
just told me to rename the grub.conf in /boot/grub and then after i had
booted the new drive that i could simply rename the file back to it's
original name uninstall lilo, and all would be well.  This failed
miserably so i read a little, recloned the drive, uninstalled lilo and
then tried the 'grub-install --root-directory=/boot /dev/hda' and also
'grub-install --root-directory=/boot /dev/hda1' command.  This time,
upon rebooting, i came to a grub prompt that i could tab through.  I
used the setup (hd0,0) command thinking then that i would possible be
able to reboot back to the original state, and still no luck.  I came
back to the grub prompt where i could tab to get the list of commands. 
Next i used 'kernel /vmlinuz' and it recognized my kernel and then i
typed 'boot' but it kernel panicked saying it couldn't mount root fs on
48:05.  I'm pretty lost and was under the impression that this would be
quite easy.  I could leave the system as a lilo system, but i prefer the
grub bootloader.  Can anyone offer some advice?

Thanks in advance

reply via email to

[Prev in Thread] Current Thread [Next in Thread]