[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

pxegrub not starting automatically the config file

From: Yedidyah Bar-David
Subject: pxegrub not starting automatically the config file
Date: Thu, 4 Mar 2004 21:32:26 +0200
User-agent: Mutt/1.4i


I have a feeling this was asked here before, but can't find it in the
archives. Sorry.

I have a machine with an eepro100 that works well with pxegrub 0.93.
I compiled it with several drivers, including eepro100. I have a new
machine that has a tigon3, so I downloaded the patches from savannah and
compiled it with all the drivers as before plus tg3, and it didn't work,
so to test I also tried it on the working machine, and it also doesn't
work. So it's not a matter of drivers, but of changes betweem 0.93 and
this patch.

What doesn't work? I have in my dhcpd.conf an option 150 that tells
grub to load a config file from the server. 0.93 does it. The new
version only gets loaded from the server and gives a GRUB> prompt.
If I manually do 'configfile (nd)/path/to/conffile' it does work and
proceed as usual. My problem is that it doesn't do that automatically,
as if it didn't get the option to load the file.

The versions I used: clean 0.93 worked. I downloaded this:
named "grub-diskless-patch-2.tar.gz" on this page:
It had 3 patch files and an index, I applied all of them, in the order
they are described in INDEX-1. All applied cleanly.
gcc 2.95.3 on RedHat 7.3.

Is this an FAQ? If not, what else should I try?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]