[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[solved] pxegrub not starting automatically the config file

From: Yedidyah Bar-David
Subject: [solved] pxegrub not starting automatically the config file
Date: Wed, 10 Mar 2004 22:25:12 +0200
User-agent: Mutt/1.4i

Hi all,

I got only one reply, off-list, which led me to a solution.
Thanks, Istvan!

His suggestion was to not apply the dhcp-hack patch. This didn't work.
But: manually deleting the dhcp-hack part from grub-0.94-1-0002.patch
(inside grub-diskless-patch-2.tar.gz) before applying it produced a
tree that does work.

0.94 + grub-0.94-diskless-1.patch.gz + grub-0.94-diskless-fixtg3.patch
doesn't work, as well as same + grub-0.94-diskless-dhcphack.patch.
Both get stuck with:
Probing pci nic...
[tg3-5703X]Ethernet addr: xx:xx:xx:xx:xx:xx
Tigon3 [partno(none) rev 1002 PHY(5703)] (PCIX:100Mhz:64-bit)
Link is up at 100Mbps, full duplex. TX RX flow control
transmit timed out
tg3_stop_block timed out, ofs=lx enable_bit=00002400

0.93 + the 3 patches inside grub-diskless-patch-2.tar.gz causes it to
hang with a different message, which I currently don't have (but can
provide, if it can help). As I wrote above, same MINUS the dhcp-hack
does work. Just to make things clear, I also put the working tree in

I will be able to reboot this machine without notice for a few more
days (maybe a few more weeks). If anyone wants me to test anything on
it, tell me.
BTW - it's an HP DL380, tigon3 onboard, connected to a 100Mb switch.
We don't have a switch with a copper Gbit port to test against.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]