[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub and FreeBSD 4.9

From: Daniel Blankensteiner
Subject: Grub and FreeBSD 4.9
Date: Thu, 20 May 2004 21:52:16 +0200
User-agent: KMail/1.6.2

Hi all

I'm trying to get grub working on my FreeBSD 4.9 test-box. So far I've done:
cd /usr/ports/sysutils/grub
make install clean
mkdir /boot/grub
cp /usr/local/share/grub-0.94/i386-freebsd/* /boot/grub/
In /boot/grub I created a fil called menu.lst and wrote this in it:
        default 0       # By default, boot the first entry.
        timeout 5       # Boot automatically after 30 secs.

        title FreeBSD
        root   (hd0,0)
        kernel /boot/loader

(I've also tried with chainloading)
My box is just a test box with one harddisk, so I've made one huge / and then
given about 256 mb to swap.

I've read that the safest way to install grub is by making a bootdisk, boot
and run setup, so I made the disk:
     # cd /boot/grub
     # dd if=stage1 of=/dev/afd0 bs=512 count=1
     1+0 records in
     1+0 records out
     # dd if=stage2 of=/dev/afd0 bs=512 seek=1
     153+1 records in
     153+1 records out
And I booted on it just fine, but I can't install grub because it by default
dones't support ffs drives. I know there is a ffs_stage1_5 in /boot/grub, but
how do I use it?

Anyway I rebooted in FreeBSD and ran "grub" and made the install
 successfully, but then booting the system again I get:
GRUB loading stage1.5.

GRUB loading, pelase wait...
Error 18
How do I fix it?

I've also tried getting network support built into grub, but I can't figure
out which driver to use (FreeBSD use de0), any ideas?

Best regards

ps: Please cc to me as I am not on the list (I already tried mailling this to 
address@hidden, but no luck there)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]