[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bugs #10433] Grub 0.95 - Grub Bootable CD-ROM, no device (cd). Related

From: Yoshinori K. Okuji
Subject: [bugs #10433] Grub 0.95 - Grub Bootable CD-ROM, no device (cd). Related to Error 21 at stage 1.5
Date: Mon, 20 Sep 2004 17:19:05 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

This mail is an automated notification from the bugs tracker
 of the project: GNU GRUB.

[bugs #10433] Latest Modifications:

Changes by: 
                Yoshinori K. Okuji <address@hidden>
                Mon 09/20/04 at 21:12 (GMT)

            What     | Removed                   | Added
          Resolution | None                      | Invalid
              Status | Open                      | Closed

------------------ Additional Follow-up Comments ----------------------------
Read the manual. Use stage2_eltorito.

[bugs #10433] Full Item Snapshot:

URL: <http://savannah.gnu.org/bugs/?func=detailitem&item_id=10433>
Project: GNU GRUB
Submitted by: Brendan Sleight
On: Sat 09/18/04 at 17:19

Category:  Booting
Severity:  Major
Priority:  5 - Normal
Item Group:  Non-software Error
Resolution:  Invalid
Privacy:  Public
Assigned to:  None
Originator Name:  Brendan Sleight
Originator Email:  address@hidden
Status:  Closed
Release:  0.95
Reproducibility:  None
Planned Release:  

Summary:  Grub 0.95 - Grub Bootable CD-ROM, no device (cd). Related to Error 21 
at stage 1.5

Original Submission:  Grub 0.95 - Grub Bootable CD-ROM, no device (cd).

I am using an IPC - Webnote. (IPC Archtec 503-060)

I am a (minor) developer with Morphix.org - a GNU/Linux LiveCD  ( 
http://en.wikipedia.org/wiki/Livecd ) We have moved away from using Grub with 
floppy disk emulation. To booting w/o emulation, using iso9660_stage1_5 (So 
that we have space for kernel, long menu lists and graphics).  When using this 
option, I get Error 21 (disk does not exist) during stage 1.5

There are no other BIOS upgrades (google suggestion) available for my machine, 
currently on highest version. Other Laptop have reported the same problem:-
acer TravelMate 290
Packard Bell Easynote E3269 (+ Another User - Packard Bell)
Toshiba Tecra S1 1.6ghz 

A have also tried making a new iso without the -boot-load-size 4 This has no 
effect on the error.

I have also created a cd-rom using grub 0.95 exactly as per the instruction in 
the documentation. Without any menu or option files.
(no emulation mode in the El Torito specification)
So that I can just boot to grub command line. The devices fd0 and hd0 do exisit 
but device (cd) does not exist.
For example I do: cat (<<TAB>>
I only get option of hd0. I am unable to access the other files on the iso.

A bug report that is mentions Error 21 (HD not CD-ROM), suggest down grading to 
I have tried this, but I get a compile error :-
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../stage1  -Wall -Wmissing-prototypes 
-Wunused -Wshadow -Wpointer-arith -malign-jumps=1 -malign-loops=1 
-malign-functions=1 -Wundef -O2 -I../lib -DGRUB_UTIL=1 -DFSYS_EXT2FS=1 
-DSUPPORT_HERCULES=1 -fwritable-strings -g -c -o libgrub_a-fsys_reiserfs.o 
`test -f fsys_reiserfs.c || echo './'`fsys_reiserfs.ccc1: warning: 
-malign-loops is obsolete, use -falign-loops
cc1: warning: -malign-jumps is obsolete, use -falign-jumps
cc1: warning: -malign-functions is obsolete, use -falign-functions
fsys_reiserfs.c:115: error: long, short, signed or unsigned used invalidly for 
fsys_reiserfs.c: In function `next_key':
fsys_reiserfs.c:761: warning: operation on `depth' may be undefined
make[1]: *** [libgrub_a-fsys_reiserfs.o] Error 1
make[1]: Leaving directory `/home/bms/grub_i/grub-0.92/stage2'
make: *** [install-recursive] Error 1
(Sorry I am not very good at compile errors - I'm still learning)

I would be greatful for any sugestions on what other tests I can try. Looks 
like there is a problem between BIOS, GNU/Grub on CD when not using floppy 
emulation. Seen in other laptops.

Best Regards,
Brendan M. Sleight

Real email: me.spam[**]barwap.com

Follow-up Comments

Date: Mon 09/20/04 at 21:12         By: Yoshinori K. Okuji <okuji>
Read the manual. Use stage2_eltorito.

CC List

CC Address                          | Comment
me --DOT-- spam --AT-- barwap --DOT-- com | 

For detailed info, follow this link:

  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]