[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

grub device mapping problem

From: Haines Brown
Subject: grub device mapping problem
Date: Thu, 23 Sep 2004 14:20:54 -0400 (EDT)

I have a problem with device mapping with 0.95+cvs20040624-8 on debian
sarge, whether stage1 is located in the HD MBR or on a grub boot
floppy. I'd like to create a clean boot floppy as a first step.

I have three scsi disks. The sda (sarge, kernel 2.4.18-bf2.4), which
can also boot sdb (RedHat 8.0, kernel 2.4.18-14) and sdc (debian
sarge, which is not yet set up to boot, kernel 2.6.7-1-386).

My BIOS sets up the disk sequence as sda, sdb, sdc. However, grub sees
sdb as (hd2) and sdc as (hd1). It sees sda properly as (hd0). To boot
these devices, I have to boot sdb as `root (hd2,0)' and sdc as `root

I tried to alter the /boot/grub/device.map file to read:

  (hd0) /dev/sda
  (hd1) /dev/sdb
  (hd2) /dev/sdc

but this had no effect. I tried a map command before root in the
menu.lst stanzas in order to remap, but this had no effect either.

The motherboard is Intel D850MVL; BIOS is Award MV85010A.86A.0011 P05.
I was able to boot these three drives under debian woody (on sda and
sdc) with an earlier version of grub (same hardware and BIOS setup,
and sdb the same as now).

I tried to create a boot floppy without luck:

 grub> install /boot/grub/stage1 d (fd0) 
          /boot/grub/stage2 p 

Is there a clean work-around? Should I file a bug report (how?). If I
install a stable version of grub, will it pull in its stable
dependencies without breaking anything else?

Haines Brown

reply via email to

[Prev in Thread] Current Thread [Next in Thread]