[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bugs #10498] Incorrect scsi device mapping

From: Haines Brown
Subject: [bugs #10498] Incorrect scsi device mapping
Date: Sat, 25 Sep 2004 15:29:40 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040413 Galeon/1.3.15 (Debian package 1.3.15-2)

This mail is an automated notification from the bugs tracker
 of the project: GNU GRUB.

[bugs #10498] Full Item Snapshot:

URL: <http://savannah.gnu.org/bugs/?func=detailitem&item_id=10498>
Project: GNU GRUB
Submitted by: Haines Brown
On: Sat 09/25/2004 at 19:23

Category:  Booting
Severity:  Major
Priority:  5 - Normal
Item Group:  Software Error
Resolution:  None
Privacy:  Public
Assigned to:  None
Originator Name:  Haines Brown
Originator Email:  address@hidden
Status:  Open
Release:  0.95+cvs20040624-8

Reproducibility:  Every Time
Planned Release:  

Summary:  Incorrect scsi device mapping

Original Submission:  A problem with device mapping with grub 
0.95+cvs20040624-8,  under debian sarge. Problem occurs whether stage1 is 
located in the HD MBR or on a grub boot floppy.

There are three scsi disks on the bus. The first is sda (sarge, kernel 
2.4.18-bf2.4, reiserfs). The sda bootloader also boots sdb (RedHat 8.0, kernel 
2.4.18-14, ext3) and sdc (debian sarge, not set up to boot yet, kernel 
2.6.7-1-386, reiserfs). 

My BIOS sets the disk sequence to be sda, sdb, sdc. 
However, grub sees sdb as (hd2) and sdc as (hd1). It sees sda properly as 
(hd0). To boot these devices, I have to 
boot sdb as `root (hd2,0)' and sdc as `root (hd1,0)'.

I tried to alter the /boot/grub/device.map file to read:

  (hd0) /dev/sda
  (hd1) /dev/sdb
  (hd2) /dev/sdc

but this had no effect. I tried a map command before root 
in the menu.lst stanzas in order to remap, but this had no
effect either. 

The motherboard is Intel D850MVL; BIOS is Award MV85010A.86A.0011 P05.

I was able to boot these three drives under debian woody 
(on sda and sdc) with  an earlier version of grub (same hardware and BIOS 

I created a boot floppy:

 grub> install /boot/grub/stage1 d (fd0) 
          /boot/grub/stage2 p 

but same mapping problem.

For detailed info, follow this link:

  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]