[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

empty initrd.img-2.6.8-1-386.new

From: Haines Brown
Subject: empty initrd.img-2.6.8-1-386.new
Date: Fri, 3 Dec 2004 11:32:07 -0500 (EST)

My previous working grub stanza was:

  title Debian sarge 2.6.8-1-386
    root (hd2,0)
    kernel /vmlinuz ro root=/dev/sdc1 apm=off 
    initrd /initrd.img 

  (initrd.img@ -> /boot/initrd.img-2.6.8-1-386)

An upgrade of packages included an upgrade of my initrd.img. The
upgrade came with an alert that my bootloader requires that I add
initrd=/initrd.img to the images=/vmlinuz stanza.

I assumed that the initrd /initrd.img command has the same effect as
the initrd=/initrd.img kernel option, and so didn't understand what
the alert was getting at.

However, I did find that the initrd upgrade changed the name of
/boot/initrd.img-2.6.8-1-386 to /boot/initrd.img-2.6.8-1-386.new. This
struck me as odd. Is that renaming to be expected? 

So I changed the symlink to reflect the name change:

  /initrd.img@ -> /boot/initrd.img-2.6.8-1-386.new 

But this resulted in a kernel panic:

  Cannot open root device 'sdc1' or unknown-block(0,0)
  Please append a correct "root=" boot option
  Kernel panic: VF8: Unable to mount root fs on unknown-block(0,0)

Since my original stanza had worked OK, I assumed the problem had to
do with the initrd.img, not difficulty locating (hd2,0) (sdc1 first

I tried changing the initrd.img command to a kernel image option, and
I tried to point directly to the /boot/initrd.img-2.6.8-1-386.new
file, but still had the kernel panic.

The only thing I can see is that /boot/initrd.img-2.6.8-1-386.new has
0 size. This is wrong, I assume. Also, the ".new" suffice strikes me
as strange and wonder if that is normal with an initrd.img upgrade.

Haines Brown

reply via email to

[Prev in Thread] Current Thread [Next in Thread]