[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bugs #11304] Dump function problem

From: Flavien Bridault
Subject: [bugs #11304] Dump function problem
Date: Sun, 12 Dec 2004 15:54:59 -0500
User-agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; fr) (KHTML, like Gecko)

This mail is an automated notification from the bugs tracker
 of the project: GNU GRUB.

[bugs #11304] Full Item Snapshot:

URL: <http://savannah.gnu.org/bugs/?func=detailitem&item_id=11304>
Project: GNU GRUB
Submitted by: Flavien Bridault
On: dim 12.12.2004 at 20:44

Category:  Installation
Severity:  Major
Priority:  5 - Normal
Item Group:  Software Error
Resolution:  None
Privacy:  Public
Assigned to:  None
Originator Name:  Vlaaad
Originator Email:  address@hidden
Status:  Open
Release:  0.95
Reproducibility:  Intermittent
Planned Release:  

Summary:  Dump function problem

Original Submission:  Hello,

Well I spent two days in order to try why I had problems with grub-install. I 
just made a new spell for Source Mage, but sometimes, I'm not able to copy grub 
to the MBR of my disk. Sometimes it works, sometimes don't work, without doing 
any changes (only time passed...)

Here is the error message :
The file /boot/grub/stage2 not read correctly.
But sometimes it can be any *stage* file... I managed to find that the problem 
came from the dump function used in grub-install via the grub-shell.
I don't know why, but the dump of the *stage* files don't work and /tmp file is 
different. After grub-install failed, I watched the /tmp/grub-install.log.* and 
the dump commmand seems ok. I launch grub-shell and try to do it but I get the 
same problem, although dump don't complain. After a lot of tests, I decided to 
copy my /boot/grub/stage2 on a partition located on a IDE disk. I tried then 
via grub-shell, to dump the copy onto /tmp/grub-install.log.* or wherever and 
then it works, the dumped file is the same as the copy, so well the same as 
So I guess there is a problem with my main disk drive, and the only hypothesis 
I can emit is that it is an SATA drive or maybe it comes from a special 
partitioning configuration, since this is the same FS as the IDE disk (ext3). 
Here is the list of partitions :

Partition num: 0,  Filesystem type is ext2fs, partition type 0x83
   Partition num: 1,  Filesystem type is fat, partition type 0xc
   Partition num: 2,  Filesystem type unknown, partition type 0x82
   Partition num: 4,  Filesystem type is ext2fs, partition type 0x83
   Partition num: 5,  Filesystem type is ext2fs, partition type 0x83

I run linux 2.6.9, gcc3.3, the problem happens with or without the various grub 
patches, and it is no more linked to any configuration option.

Do you have any explanation, suggestion ??

For detailed info, follow this link:

  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]