[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Can't boot after installing xen packages.

From: zephod
Subject: Can't boot after installing xen packages.
Date: Sat, 13 Jan 2007 14:45:36 -0500

The short story: 

I updated my FC5 instalation to FC6 and all appeared to go well. When 
the system rebooted, I installed all the latest packages and again, no 
problems. Then I decided I wanted to look at xen so I downloaded the 
kernel-xen package and 2 other related packages. Now the system will 
not boot. No hint of grub even starting.

The details:

I have a Pentium 4 3.4GHz system with 1GB RAM, the motherboard is an 
ASUS P5GD2-Deluxe and came with a 120GB SATA HD. I had a 160GB IDE 
drive containing my Linux partitions from a previous computer that I 
wanted to install in my new computer and make this a dual boot system 
with Windows on the 120G HD and Linux on the 160 HD.

Well, I should have done a little research before I bought the new 
computer. I discovered that I cannot mix the SATA and the IDE drives. 
In the end I installed an IDE controller I had lying around and hooked 
the IDE drive up to that. I didn't want to install GRUB on the Windows 
disk so I put it in the MBR of the Linux disk. I wasn't able to boot 
into Windows from GRUB but I didn't spend any time looking into the 
problem and just used the BIOS to boot into Windows when I needed to.

I first tried changing which kernel to boot but in the end I found 
that the problem is the root command. If I boot into rescue mode from 
the DVD and enter GRUB interactively:

# grub
grub> root (hd0,0)
   Filesystem type unknown, partition type 0x7

So why doesn't GRUB recognize the partition type and what is type 0x7?

fdisk shows this:

# fdisk -l /dev/hdi

Disk /dev/hdi: 160.0GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cyclindes of 16065 * 512 = 8225280 bytes

  Device  Boot Start  End   Blocks    Id System
/dev/hdi1   *    1     13    104391   83 Linux
/dev/hdi2        14   19457 156183930 8e Linux LVM

The file /boot/device.map contains:
 (hd0) /dev/hdi
 (hd1) /dev/sda

(For some reason /dev/hdi has become /dev/hdk now)

All this looks OK to me. 

Can someone give me some ideas about how to debug this or perhaps 
inform me that what I am trying to do is impossible and it shouldn't 
have worked in the first place.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]