[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug #19070] Grub/LVM boot problem

From: JKoshi
Subject: Re: [bug #19070] Grub/LVM boot problem
Date: Thu, 22 Feb 2007 09:07:26 -0800 (PST)


Thanks for your feedback.

The disks are laptop disks, and I don't have an easy way to
look at both of them in a system at the same time.

The interesting thing is I can boot the system with a Linux
rescue CD, (with the cloned disk in place), and see all my
directories and files when mounted. If any of the LVM data
structures were corrupted, I'm thinking this may not have
been possible.

Grub seems to complaining about the initrd image, but I'm not
sure of this, since it complains even with a rebuilt initrd.

Acronis works almost like dd, and can do a verbatim copy of a
disk. I looked into everything else, before I went with this.
I'll probably revisit using dd for this purpose, if this can
not be resolved.


Web Clark (RR) wrote:
> No answers, but some ideas.
> Since you tried to boot, perhaps something changed. Just to be squeaky
> clean, re-clone your disk.
> Put both disks into a PC. For example as master and slave of IDE0.
> Next boot a linux CD (Knppix 5.01 or later).
> Compare the two disks:
> cmp /dev/hda /dev/hdb
> If they are not identical, they are not identical!
> I don't recall if cmp tells you the byte offset where the difference is
> encountered, but this would be useful. Surely there is a utility that
> will do this, else write one.
> I recall that the md driver (Linux RAID) puts stuff in the last 64K or
> some such of a partition. I wonder if LVM puts anything in the end of
> the volume? I don't know anything about Acronis, but perhaps if LVM puts
> something in an unused area at the end of the last cylinder, perhaps
> Acronis did not copy it, and so LVM is missing information.
> Also, any Windows disk cloner may not copy the entire first track, so
> anything embedded there won't be preserved in your clone!
> Also different programs build partitions different with respect to where
> partitions start - on a cylinder boundary or not. There are many
> permutations. If your restorer rebuilds partitions instead of copying
> the disk bit-for-bit, sector-for-sector (Which is likely since your note
> implied that you did not have to restore to a disk of the same
> geometry), then the partitions on the clone may not be placed exactly as
> they are in the original. If you embedded absolute disk addresses when
> you installed grub, the stuff will not be in the same place. Some
> configurations of Grub do this.
> Good luck. I suggest using a Linux disk and use dd piped to gzip -c to
> save partitions instead of the entire disk. To restore you just make a
> partition the same size or bigger on your new disk and put it back (any
> extra size being wasted). Dumb, simple, and effective. For linux use
> "dump". Again, simple and effective. Any bootable Linux CD becomes your
> rescue disk.
> --Ray
> JKoshi wrote:
>> Hi,
>> I have a problem with the grub bootloader, as follows. I have a
>> laptop, with an 80G disk, with Windows XP on the first half of
>> the disk (NTFS), and Fedora core 4 (LVM) on the rest. Dual boot
>> is managed by grub, installed with the Fedora install.
>> I wish to clone this disk, so I don't lose hours of setup/installs
>> on both OS's, and my work, in case of a crash. I did the following:
>> 1) Installed Acronis 10 under Windows, and cloned the entire disk
>>    to a 120G USB disk.
>> 2) Restored from that clone onto a new 80G disk of the same geometry,
>>    and replaced the existing disk with the newly cloned one.
>> 3) On start-up, got a grub hang, so did the following:
>>       a) Boot from Fedora core 4 rescue CD
>>       b) chroot /mnt/sysimage
>>       c) grub-install /dev/hda
>>       d) Enter grub
>>       e) grub> find /grub/stage1 -> gave me (hd0,3)
>>       f) grub> root (hd0,3)
>>       g) grub> kernel /vmlinuz-2.6.17-1.2142_FC4 ro root=/dev/hda4
>>       h) grub> initrd /initrd-2.6.17-1.2142_FC4.img -> gave me 
>>                     "Error 16: Inconsistent filesystem structure"
>>       i) Exit grub, repeat to step b) above, and rebuild initrd:
>>          "mkinitrd -v -f initrd-2.6.17-1.2142_FC4.img 2.6.17-1.2142_FC4"
>>       j) Repeat from d) again, and get the same Error 16 as above.
>> 4) Note that after step 3-c) above, I got past the grub hang, and was
>> able
>>    to boot Windows. But selecting the Linux installation gave me "Error
>> 17:
>>    Cannot mount selected partition". That's when I did the remaining
>> steps
>>    above.
>> Sorry about the long-winded explanation, but this is frustrating, and I
>> wanted to provide all the details, in the hope that some-one could throw
>> some light on the dark innards of grub vis-a-vis LVM, to resolve this.
>> Thanks in advance.
>> regards,
>> John
> _______________________________________________
> Bug-grub mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/bug-grub

View this message in context: 
Sent from the Grub - Bugs mailing list archive at Nabble.com.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]