[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #29285] grub2 doesn't see logical partitions correctly on usb hdd

From: dimas
Subject: [bug #29285] grub2 doesn't see logical partitions correctly on usb hdd
Date: Mon, 22 Mar 2010 18:23:30 +0000
User-agent: Opera/9.80 (X11; Linux i686; U; en) Presto/2.2.15 Version/10.10

Follow-up Comment #1, bug #29285 (project grub):

well... i've repartitioned the whole drive several times, including
zero-cleaning of partition table. and what i noticed after it all: grub cannot
recognize extended partition in any way!
firstly, when there is only 400G sdb1, all is fine. but when i create
extended sdb2 in rest of space, it cannot be seen in grub. "ls" displays (hd1)
and (hd1,1) and says "error: no signature". so there is no sdb2 at all. and it
doesn't see anywhere created in extended sdb2.
btw, i've tried type 5 and type 85 and results were same. i've tried with
fdsik, cfdisk and gparted - the same.
what is more - when i left idea about extended partition here and just
created 3 primary partitions
sdb1 - 400G - ntfs
sdb2 - 15G - reiser
sdb3 - 4G - reiser
i've got strange results too. "ls" displays all of them, but only sdb1 is
displayed as ntfs. sdb2 and 3 is shown like "unknown filesystem", so i
couldn't browse their contents or do smth useful.
oh, forgot to mention: i got latest trunk from bzr, built and installed it.
it works, but nothing changed with my problem.
and... grub-emu doesn't see hd1 at all, but i'm not sure if it should
don't know which extra-info to provide. can get smth more if you need


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]