[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #34973] No boot linux partitions in second hard drive

From: Jorge A. García
Subject: [bug #34973] No boot linux partitions in second hard drive
Date: Sat, 03 Dec 2011 05:39:25 +0000
User-agent: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0


                 Summary: No boot linux partitions in second hard drive
                 Project: GNU GRUB
            Submitted by: kamesennin
            Submitted on: sáb 03 dic 2011 05:39:24 GMT
                Category: Booting
                Severity: Major
                Priority: 5 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: Jorge A. García
        Originator Email: address@hidden
             Open/Closed: Open
         Discussion Lock: Any
                 Release: other
         Reproducibility: None
         Planned Release: None



I have a PC that worked with no problems previous versions of Ubuntu Oneiric
Ocelot, with two SATA Hard drives, the first with Windows/Dell restore
partitions and the second with a NTFS partition and Ext3 (or 4) for
When I upgraded the distribution to Oneiric (grub 1.99 I think), I didn't get
any error message. But when I rebooted the system, I get an error message from
Grub "Error: No such device" + an UUID number and the grub rescue prompt.

Until I know, Grub loader always was installed in sda and grub in sdb linux
partitions and worked fine with this configuration until the upgrade.

After that issue, I couldn't boot the computer under windows neither linux, I
re-made the MBR with windows rescue disc, and re-installed linux in the first
hard drive and now works with no problem, but when I tried to install another
distro in the second hard drive I received the same error message from grub:
"No such device " + an UUID number. I needed to run a grub-repair disc or a
update-grub in order to make the system bootable again after another distro
installation. I looked for the bugs reports but only the bug#34344 is slightly
similar and recently the bug#34965, but I don't have problem with UUIDs or
booting after grub re-configuration (grub-repair or update-grub).

I can't give an interpretation to the results of commands such as strace
grub-probe --device /dev/sda --target=abstraction but in the first line of the
output says "grub-probe: information: can't open <</boot/grub/device.map>>. So
I looked for that file and there wasn't any place. After that, I re-made the
file with the grub-mkdevicemap command and update-grub after, this is the
contents of device.map

(fd0)   /dev/fd0
(hd0)   /dev/disk/by-id/ata-WDC_WD5002AALX-00J37A0_WD-WCAYUX024342
(hd1)   /dev/disk/by-id/ata-WDC_WD2500JS-08NCB1_WD-WCANK9267554  

Nevertheless, after the creation of device.map file, the unbootable partitions
in the second hard drive continues. Even in the grub boot menu are visible the
new distros items but they aren't bootable and when I selected one of this
distros I get now "No such device. No such partition. You need to load the
kernel first" new error message.
I understand that I have grub 1.99 from the final release of Ubuntu CD. Ubuntu
in the first hard drive works with no problems even I can explore and read the
files contained in the "unrecognized" partitions in the second hard drive.


File Attachments:

Date: sáb 03 dic 2011 05:39:24 GMT  Name: grub-probe.txt  Size: 6kB   By:

Date: sáb 03 dic 2011 05:39:24 GMT  Name: recheck.txt  Size: 300B   By:

Date: sáb 03 dic 2011 05:39:24 GMT  Name: strace.txt  Size: 103kB   By:



Reply to this item at:


  Mensaje enviado vía/por Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]