[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #34979] GRUB, error: hd0 out of disk (with linux installed in a sec

From: Jose Alberto
Subject: [bug #34979] GRUB, error: hd0 out of disk (with linux installed in a second disk)
Date: Sat, 03 Dec 2011 17:52:19 +0000
User-agent: Opera/9.80 (Windows NT 6.1; U; es-ES) Presto/2.9.168 Version/11.52


                 Summary: GRUB, error: hd0 out of disk (with linux installed
in a second disk)
                 Project: GNU GRUB
            Submitted by: josealb77
            Submitted on: sáb 03 dic 2011 17:52:18 GMT
                Category: Booting
                Severity: Major
                Priority: 5 - Normal
              Item Group: Software Error
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: josealb77
        Originator Email: address@hidden
             Open/Closed: Open
         Discussion Lock: Any
                 Release: other
         Reproducibility: Every Time
         Planned Release: None



I've tried to solve this issue in the linux mint debian edition forum but they
don't know how to help me on, this is the message I wrote there and here is
where you can find the post:

I boot the linuxmint-201109-xfce-dvd-64bit in live-dvd, then I install it,
reboot, and get this message:
[quote]GRUB loading…
Welcome to GRUB!
error: hd0 out of disk.
Entering recue mode…
grub rescue>[/quote]

I've got two HDD, a serial ATA with windows 7 and two more partition for games
and files, and an ATA HDD with a swap partition, a linux mint ext4 one and
finally an ext4 partition for /home. In the BIOs I've got selected the serial
as first HDD and the ATA (a Maxtor HDD), as second HDD. In order to boot linux
I've got to access to the boot menu (pressing F8 during the BIOS booting), but
this is this way because I prefer it so.

Recently I installed the gnome version of linux mint
(linuxmint-201109-gnome-dvd-64bit), and happened the same, I reinstalled it
and was solved by itself, but with the xfce version I've already installed 4
times but it isn't solved by itself.

During the instalation with the installer I formated the 3 partitions (swap, /
and /home) and selected the mounting points that way. Selected GRUB to be
installed in /dev/sdb (the ATA HDD, sda it's the serial ATA, I want this to be
that way because I want to leave the serial HDD untouched and whenever I had
to use linux boot it with the BIOS' F8 (boot) menu).

I've followed these steps from the webpage
[url]https://help.ubuntu.com/community/Grub2[/url] but I finish with the same
error message:
[b]GRUB 2 Troubleshooting Preparation[/b]

GRUB loading…
Welcome to GRUB!
error: hd0 out of disk.
Entering recue mode…
grub rescue> set
grub rescue> ls
(hd0) (hd0,msdos3) (hd0,msdos2) (hd0,msdos1) (hd1) (hd1,msdos7) (hd1,msdos6)
(hd1,msdos2) (hd1,msdos1) (cd)
grub rescue>ls (hd0,msdos2)/
./ ../ lost+found/ home/ bin/ boot/ dev/ etc/ lib/ lib64 media/ mnt/ opt/
proc/ root/ run sbin/ selinux/ srv/ sys/ tmp/ usr/ var/ initrd.img vmlinuz
grub rescue> ls (hd0,msdos2)/boot
./ ../ boot/ grub/ System.map-2.6.39-2-amd64 config-2.6.39-2-amd64
initrd.img-2.6.39-2-amd64 vmlinuz-2.6.39-2-amd64
grub rescue> ls (hd0,msdos2)/boot/grub
(lots of files .mod; grub.cfg; .img; etc...)

[b]Rescue Mode (''grub rescue>'') Booting[/b]

grub rescue> set prefix=(hd0,msdos2)/boot/grub
grub rescue> set root=(hd0,msdos2)
grub rescue> insmod normal
error: hd0 out of disk
grub rescue> insmod (hd0,msdos2)/boot/grub/normal.mod
error: hd0 our of disk
What can I do?

I think the trouble is that Grub is not well autoconfigured when the linux
partition is in a second disk. Grub mess when it's installed in a second

As I said, what can I do?


Reply to this item at:


  Mensaje enviado vía/por Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]