[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #34979] GRUB, error: hd0 out of disk (with linux installed in a sec

From: Jose Alberto
Subject: [bug #34979] GRUB, error: hd0 out of disk (with linux installed in a second disk)
Date: Sun, 04 Dec 2011 01:01:23 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0

Follow-up Comment #2, bug #34979 (project grub):

Wuow!! Almost solved at first!
I tried first installing with the modules ata and ahci but for both I got an
error message. As this didn't work I parted the HDD this way:

/dev/sdb1   ext4         400.00 MiB   /boot
/dev/sdb2   linux-swap     1.95 GiB   /swap
/dev/sdb3   ext4          39.39 GiB   /
/dev/sdb4   extended     148.19 GiB   
/dev/sdb5   ext4         148.19 GiB   /home

Rebooted and... tachan! Finally the "graphic" menu appeared with 3 options:
"LinuxMint", "LinuxMint (repair)" and "Windows 7 (on /dev/sda)" but... another

any option I choose makes my system reboot before anything be loaded. Any of
the 3 that appear.

On the first option (LinuMint, the default one) I've pressed "e" like if I
were going to edit something and this is the code that appeared:

GNU GRUB version 1.99-8
setparams 'LinuxMint etc.'
insmod gzio
insmod part-msdos
insmod ext2
set root='(/dev/sdb,msdos1)'
search --no-floppy --fs-uuid --set-root 80035a85-b997-4223-9e52-bc24440
echo 'Loading Linux 2.6.39-2-amd64 ...'
linux /vmlinuz-2.6.39-2-amd64 root=UUID=6cb9feah-30bc-4ae8-9098-c5e70e4
4bc4a ro quiet
echo 'Loadong initial ramdisk ...'
initrd /initrd.img-2.6.39-2-amd64

When I pressed intro appear some letters in the left-up corner of the screen
for a fraction of second but suddenly the computer reboot by itself. I think
the letter that appears are "Loading Linux 2.6.39-2-amd64", but I haven't got
time enough to read them, it reboots too soon.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]