[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Assortment of Issues with EFI on Mac

From: Jake Thomas
Subject: Re: Assortment of Issues with EFI on Mac
Date: Tue, 3 Jan 2012 18:57:15 -0800 (PST)

Hello again, Vladimir. I know you're probably not back yet, but I figure I better get this posted while I have time and it's fresh in mind.

About the blackout bug (or lack thereof), I tried 3 different things, neither of which cured the blackout.

1. Followed "set root=(hd0,gpt3)" with "search --no-floppy --fs-uuid --set=root EEBB-91C6" (new line below)

2. Removed "set root=(hd0,gpt3)", leaving "search --no-floppy --fs-uuid --set=root EEBB-91C6"

3. Tried just your  "search -s  root -u EEBB-91C6" (no "set root=(hd0,gpt3)" or "search --no-floppy --fs-uuid --set=root EEBB-91C6")

However, again, when I delete grub.cfg, this forces it into a working commandline. There I toyed around. My thumb drive was again hd0 (but I believe you that with some firmwares it's possible for the booted drive to not be first). I set the root to (hd1,gpt1) to see if the "set by UUID" commands work. I tried "search --no-floppy --fs-uuid --set=root EEBB-91C6", and sure enough, my root was put back to (hd0,gpt3). I put it back to (hd1,gpt1), and tried your "search -s  root -u EEBB-91C6", which also set the root back to (hd0,gpt3).

So that proves that the syntax was dead-on. It looks like the blackout is not related to a drivemapping or UUID issue.

I got a wee bit more intel. When it blacks-out, it says "Welcome to Grub!" like usual, then "error: "prefix" is not set", which is the norm for me even when it doesn't black-out, and then it spits something on the screen too briefly to read. So I filmed it with a camera and reviewed the footage.

I couldn't make the letters out well, but here's the gist:

video/efi.???.c:248: GOP:codeo
video/efi.???/c:334: GOP:initializing FS @ ??..........

The only parts I'm sure about are the "video/efi.???" and the "initializing". The numbers and everything else are sheer guesses.

This may seem to lead us into thinking that there is a video issue. But when it doesn't blackout, the video works great, and the grub.cfg file is identical to when it blacks-out and when it doesn't black-out. I'm thinking it must be something the firmware saves in NVRAM to change it's behavior every-other time or so to make it through a fit half the time. I don't see how anything in my grub.cfg can be wrong if it works sometimes (other than the UUID thing - that makes sense).

Here's the "settings" part of my grub.cfg (everything else is menu entries):

set default="0"
set timeout=100
set root=(hd0,gpt3)
set debug=video
insmod efi_gop
loadfont /boot/grub/unicode.pf2
set gfxmode=3488x2228
set gfxmode=keep
insmod gfxterm
terminal_output gfxterm
terminal gfxterm
insmod gettext
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
insmod jpeg
background_image /SysPics/CH.jpg


reply via email to

[Prev in Thread] Current Thread [Next in Thread]