[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #36740] FTDI USB Serial Device not recognized and "insmod ehci" fre

From: Ales Nesrsta
Subject: [bug #36740] FTDI USB Serial Device not recognized and "insmod ehci" freezes grub
Date: Sun, 16 Dec 2012 18:18:34 +0000
User-agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0 Iceweasel/17.0

Follow-up Comment #16, bug #36740 (project grub):

I borrowed FTDI USB/serial converter to test the HW compatibility with GRUB.
Borrowed device has the same USB ID 0403:6001 - but it is FULL speed device,
not HIGH speed as Horst have. I hope it doesn't matter.
For the first look it seems to be working well - GRUB recognizes this device
and works with it (e.g. serial_usb0).

I tried connect another computer with PuTTY application to GRUB via serial
line and FTDI - to use PuTTY as second GRUB console.
I used on GRUB side these commands:
terminal_input console serial_usb0
terminal_output console serial_usb0

It worked well - I didn't find any problem.

So, I hope, if my previously mentioned/sent patch is correct, it looks You can
be satisfied :-)

I tested the patch on my PC if it doesn't make some regression etc. - it looks
to be OK.
But I still did not test Your (Horst) configuration, i.e. correct function of
chain EHCI -> USB 2 hub -> USB 1 hub -> low/full speed device - because I
still didn't receive USB 1 hub.
It is not so easy to get USB 1 hub nowadays, there are USB 2 only... :-(



Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]