[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #40935] Raid Corruption Failed Boot normal.mod not found

From: Lee
Subject: [bug #40935] Raid Corruption Failed Boot normal.mod not found
Date: Tue, 17 Dec 2013 11:44:18 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36


                 Summary: Raid Corruption Failed Boot normal.mod not found
                 Project: GNU GRUB
            Submitted by: numenory
            Submitted on: Tue 17 Dec 2013 11:44:18 GMT
                Category: Booting
                Severity: Major
                Priority: 5 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: 
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
                 Release: other
         Reproducibility: None
         Planned Release: None



I have just encountered what I believe to be a strange bug involving grub2.

System bios based 2007 pc
Raid 10 - (not manaually constructed) All under / no seperate parttions other
than swap.
Ubuntu 13.04 standard 3.8 kernel
Grub2 as included by distro


Did an apt-get dist-upgrade to install the vary latest kernel on 14/12/13 (not
a full system upgrade)

Grub looked to update fine, and the system has had the kernel updated before.

Rebooted, Grub dropped to Rescue mode with the error "normal.mod not found"

Booted to http://www.sysresccd.org live cd

The raid array came up, and i mounted it.

Checked that /boot/grub/i386-pc/normal.mod existed, it did and i386-pc
directory looked fine.

Chrooted the system, and tried most of the suggestions found around google
involving re-installing grub or using apt to completely purge and then
re-install, all of which completed without complaint.  After rebooting in each
instance still the /boot/grub/i386-pc/normal.mod not found.

Then at the grub rescue prompt i did 'ls /boot/grub/i386-pc/' and instead of
the list of files i saw (and subsequently re-saw) garbage or more accurately
what looked to be the contents (about 1 lines worth) of a csv file containing
data about books (one of these would have been on the system).  I re-booted to
the live cd and double checked i386-pc looked perfect.  I ran an fsck -f on
the array and also forced an mdadm check and then an mdadm resync, no
complaints from any of the processes. Still no boot and same error.

At this point I used seagate seatools live cd to check each of the 250gb hard
disks (wd2550ys) 5 in total.  The raid 10 array consisted of 4 live disks (2
near-copies) and 1 redundant spare.  One of the live disks had some sector

I pulled the drive with the errors on it, replaced with a clean drive, booted
once again to system rescue cd, let the degraded array sort itself out, added
my clean disk in as a spare and rebooted.

No boot, but no error message, system appeared to look for the bootloader on
the fresh disk.  Rebooted pressed esc and manually chose a different disk,
system booted.  Installed grub to the fresh disk, system fine once more.

The only conclusion that I can draw is that linux reads a software raid array
in a different manner to grub when there have been bad sectors, linux can
still see the information correctly grub cannot.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]