[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #45279] grub-install error on LVM-system without separate boot part

From: Jayson Willson
Subject: [bug #45279] grub-install error on LVM-system without separate boot partition
Date: Mon, 08 Jun 2015 19:15:36 +0000
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0


                 Summary: grub-install error on LVM-system without separate
boot partition
                 Project: GNU GRUB
            Submitted by: jaysonwillson245
            Submitted on: Mon 08 Jun 2015 07:15:35 PM GMT
                Category: Configuration
                Severity: Major
                Priority: 5 - Normal
              Item Group: Software Error
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: 
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 2.02~beta1
         Reproducibility: Every Time
         Planned Release: None



I have a system with LVM-partitioning on EFI. I have no separate /boot
partition, but I have 100mib fat32 partition for /boot/efi.

Every time I run grub-install, i see the following error:
" File descriptor 4 (/dev/sdb1) leaked on vgs invocation. Parent PID
blablabla: grub-install" where /dev/sdb1 is my "/boot/efi" partition, which is
outside LVM and is mounted.

I tried creating a separate /boot partition (/dev/sdc1) and if I unmount
/dev/sdb1 from /boot/efi, then mount /dev/sdc1 to /boot and then /dev/sdb1 to
/boot/efi and run grub-install - I experience no problems. But if I unmount
all these partitions and mount /boot/efi to /boot (without separate /boot) I
experience this problem again. 


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]