[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [openbsd] 2.02-beta3: build fails - getroot.c:(.text+0x2b): undefine

From: Vladimir 'phcoder' Serbinenko
Subject: Re: [openbsd] 2.02-beta3: build fails - getroot.c:(.text+0x2b): undefined reference to `getrawpartition'
Date: Thu, 17 Mar 2016 16:04:00 +0000

The real problem is .hash section. We need to strip it

Le jeu. 17 mars 2016 16:54, Andrei Borzenkov <address@hidden> a écrit :
17.03.2016 13:12, Jiri B пишет:
> On Mon, Mar 14, 2016 at 09:46:20PM +0300, Andrei Borzenkov wrote:
>>>>> $ tar tzvf /home/jirib/openbsd/packages/amd64/all/grub-2.02-beta3.tgz | grep lzma_decompress
>>>>> -r-xr-xr-x  1 root     bin           3904 Jan  1  1970 lib/grub/i386-pc/lzma_decompress.image
>>>>> -r--r--r--  1 root     bin      134480024 Jan  1  1970 lib/grub/i386-pc/lzma_decompress.img
>>>> [...]
>>>> No. Something went wrong with section addresses/offsets. Please test
>>>> 2.02~beta2 - do you observe the same problem? Please upload
>> Did you test beta2?
> Hi, sorry for delay. Yes I tried beta2, same result.
>>>> lzma_decompress.image. Where obcopy comes from (obcopy --version)? What
>>>> assembler is used?
>>> $ objcopy -V
>>> GNU objcopy 2.17
>>> Copyright 2005 Free Software Foundation, Inc.
>>> This program is free software; you may redistribute it under the terms of
>>> the GNU General Public License.  This program has absolutely no warranty.
>>> [...]
>> I asked lzma_decompress.image, not img. img is too late.
> I apologize, I missed valid filename. So here as lzma_decompress.image from beta3
> (as beta2 got same huge img file).
> http://afterboot.cz/pub/lzma_decompress.image
> SHA256 (lzma_decompress.image) = 3968a35c3fc2570cf1a888179433f23a7319d104c8622c71e501f4ba6ca38308

Well, your compiler managed to create shared library instead of
executable file:

address@hidden:~$ LANG=C objdump -f Загрузки/lzma_decompress.image

Загрузки/lzma_decompress.image:     file format elf32-i386
architecture: i386, flags 0x00000050:
start address 0x00008200

I get the same if I explicitly add -shared to linker flags.

Could you test with

./configure TARGET_LDFLAGS=-static

Bug-grub mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]