[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #55601] Icon not showing for Manjaro linux

From: fred
Subject: [bug #55601] Icon not showing for Manjaro linux
Date: Tue, 29 Jan 2019 04:18:00 -0500 (EST)
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0


                 Summary: Icon not showing for Manjaro linux
                 Project: GNU GRUB
            Submitted by: fredpz
            Submitted on: Tue 29 Jan 2019 09:17:58 AM UTC
                Category: User Interface
                Severity: Major
                Priority: 5 - Normal
              Item Group: Software Error
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: 
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 2.02
         Reproducibility: Every Time
         Planned Release: None



Steps to reproduce:

- Make a virtual box in dual boot with 2 different OSes : Ubuntu and Manjaro.

- Run grub-install from Ubuntu.

- Install a theme that includes an icon for Manjaro linux. In my case, I am
using this one <https://www.gnome-look.org/p/1280604/>, but it happens for all
the themes I have tried.

- Update grub (grub-mkconfig ...)

- Reboot

The Manjaro item does not show an icon next to its line.

This is the corresponding portion from grub.cfg

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Manjaro Linux (18.0.2) (on /dev/sda3)' --class manjarolinux --class
gnu-linux --class gnu --class os $menuentry_id_option
'osprober-gnulinux-simple-d71c8a73-25ec-41c5-a631-6d4da0f19e87' {
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos3'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root
--hint-bios=hd0,msdos3 --hint-efi=hd0,msdos3 --hint-baremetal=ahci0,msdos3 
          search --no-floppy --fs-uuid --set=root
        linux /boot/vmlinuz-4.19-x86_64
root=UUID=d71c8a73-25ec-41c5-a631-6d4da0f19e87 rw quiet
        initrd /boot/intel-ucode.img

The icon is located in the folder /boot/grub/themes/THEME/icons where all
other (working) icons are. I tried the following names:
- manjarolinux.png
- manjaro.png
- manjaro-linux.png

If I remove the icon altogether, it falls back to the gnu-linux.png icon (as
expected) ; almost as if the manjaro icon is detected but not used.


Reply to this item at:


  Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]