[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: %gs:0 thread pseudoregister in oskit-mach

From: Jeroen Dekkers
Subject: Re: %gs:0 thread pseudoregister in oskit-mach
Date: Tue, 23 Apr 2002 19:08:08 +0200
User-agent: Mutt/1.3.28i

On Sun, Apr 21, 2002 at 03:26:56PM -0400, Roland McGrath wrote:
> > You forgot to make the page table entries also user accessible. Other
> > than that, everything works perfect. Thank you.
> Great.  Thanks for the fix, and thanks for testing.  Have you/can you also
> test to be absolutely sure that users cannot access anything but the one
> word from %gs, and that they cannot access >VM_MAX_ADDRESS using %ds
> (i.e. normal accesses)?  I'm pretty darn sure that is all correct, but just
> to be paranoid.

I tried to acces %gs:4 and this failed with an "illegal
instruction". I also tried to access 0xc0000000 which got a
segmentation fault. I don't know if I have to test more.

Jeroen Dekkers
Jabber supporter - http://www.jabber.org Jabber ID: jdekkers@jabber.org
Debian GNU supporter - http://www.debian.org http://www.gnu.org
IRC: jeroen@openprojects

Attachment: pgpEp13UawFXL.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]