[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU Mach 2's serial console doesn't work?

From: Roland McGrath
Subject: Re: GNU Mach 2's serial console doesn't work?
Date: Wed, 6 Nov 2002 13:30:11 -0500 (EST)

> I just tried to boot OSKit Mach with a serial console.  It doesn't work
> anymore!  Has anybody got it to work recently, or can reproduce this bug? 
> Does anybody have two serial cables to debug this?  (Else I have to buy
> another one).

An overpriced cable only costs 256MB of SDRAM or so. :-> (Of course, if the
stores near you are like the one I went to in San Francisco, they won't
have a decent selection of serial cables and will tell you that "everything
you want uses USB now", and I dare you to try to explain serial console or
remote gdb to these people.)

> Here is what happens (in minicom with GRUB on serial console):

Btw, I use conserver always now and the logging as well as the simple
interface (closer to cu than minicom) are handy.  

I definitely get more output from the serial console than what you showed.
It is fine in oskit test kernels.  Have you tested that first?
e.g. I am using netboot from oskit/boot/net and it works fine, I can
interact with it on the console.  I have never tried CONS_COM=2, only
CONS_COM=1 with or without GDB_COM=2--I don't know a reason it should be
broken, but it might be.

My oskit-mach spits out device probe msgs and "No bootstrap code loaded
with the kernel!" successfully on the serial console.  I haven't actually
tried console input to oskit-mach any time recently.

Btw, -h is superfluous when you set CONS_COM.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]