bug-hurd
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[patch #3386] Add repeater and mouse support to the console


From: Marcus Brinkmann
Subject: [patch #3386] Add repeater and mouse support to the console
Date: Thu, 23 Sep 2004 19:36:04 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040413 Galeon/1.3.15 (Debian package 1.3.15-2)

This mail is an automated notification from the patch tracker
 of the project: The GNU Hurd.

/**************************************************************************/
[patch #3386] Latest Modifications:

Changes by: 
                Marcus Brinkmann <marcus@gnu.org>
'Date: 
                Thu 09/23/04 at 23:28 (Europe/Berlin)

            What     | Removed                   | Added
---------------------------------------------------------------------------
            Priority | 5 - Normal                | 7 - High


------------------ Additional Follow-up Comments ----------------------------
Here my notes so far, mostly for the libcons patch.

libcons:

vcons.h:

* Always document global definitions in header files.  Developers look there
  first (well, I do).

* Pay attention to name space issues.  MOUSE -> CONS_VCONS_MOUSE

* MOUSE_MOVE_PROC -> MOUSE_MOVE_ABS_PERCENT

* cons_vcons_move_mouse is not documented.

opts-std-startup.c:

* #define DEFAULT_MOUSE_SENS_STRING STRINGIFY(DEFAULT_SLACK)
  c&p error, should be (DEFAULT_MOUSE_SENS)

* beautify help output: lowercase the arguments to --mouse-show.

* How about --mouse-show-on= ?  This seems to be more legible.  Same for other.

* global mouse sensitivity is ok, we need per-device sensitivity, too, though

vcons-move-mouse.c

* Don't access flags before taking lock.

* "a xterm" -> "an xterm" (you say "eks" for x, so there is a vowel at
  the beginning, although it's not written).

* Implement

priv.h:

* CONSEVT_ -> CONS_EVT_ is more readable I think.  MOUSEMOVE -> MOUSE_MOVE
  MOUSEBUTTON -> MOUSE_BUTTON.  KEYPRESS -> KEY ?  Not sure about the last one.
console:

console.c:

* Document console_move_mouse().  There's a useless statement in there
  (vcons = active_vcons is twice).








/**************************************************************************/
[patch #3386] Full Item Snapshot:

URL: <http://savannah.gnu.org/patch/?func=detailitem&item_id=3386>
Project: The GNU Hurd
Submitted by: Marco Gerards
On: Thu 09/23/04 at 21:40

Category:  Console
Priority:  7 - High
Resolution:  None
Privacy:  Public
Assigned to:  marcus
Originator Email:  
Status:  Open


Summary:  Add repeater and mouse support to the console

Original Submission:  This patches add support for mouse support to both
libcon and the console client.  The event mechanism of
libcons was generalised.

The patch also adds repeater support to the console client.


Follow-up Comments
------------------


-------------------------------------------------------
Date: Thu 09/23/04 at 23:28         By: Marcus Brinkmann <marcus>
Here my notes so far, mostly for the libcons patch.

libcons:

vcons.h:

* Always document global definitions in header files.  Developers look there
  first (well, I do).

* Pay attention to name space issues.  MOUSE -> CONS_VCONS_MOUSE

* MOUSE_MOVE_PROC -> MOUSE_MOVE_ABS_PERCENT

* cons_vcons_move_mouse is not documented.

opts-std-startup.c:

* #define DEFAULT_MOUSE_SENS_STRING STRINGIFY(DEFAULT_SLACK)
  c&p error, should be (DEFAULT_MOUSE_SENS)

* beautify help output: lowercase the arguments to --mouse-show.

* How about --mouse-show-on= ?  This seems to be more legible.  Same for other.

* global mouse sensitivity is ok, we need per-device sensitivity, too, though

vcons-move-mouse.c

* Don't access flags before taking lock.

* "a xterm" -> "an xterm" (you say "eks" for x, so there is a vowel at
  the beginning, although it's not written).

* Implement

priv.h:

* CONSEVT_ -> CONS_EVT_ is more readable I think.  MOUSEMOVE -> MOUSE_MOVE
  MOUSEBUTTON -> MOUSE_BUTTON.  KEYPRESS -> KEY ?  Not sure about the last one.
console:

console.c:

* Document console_move_mouse().  There's a useless statement in there
  (vcons = active_vcons is twice).








File Attachments
-------------------

-------------------------------------------------------
Date: Thu 09/23/04 at 21:41  Name: console_repeater.diff  Size: 65.73KB   By: 
marco_g

http://savannah.gnu.org/patch/download.php?item_id=3386&amp;item_file_id=3697

-------------------------------------------------------
Date: Thu 09/23/04 at 21:40  Name: libcons_repeater.diff  Size: 17.08KB   By: 
marco_g

http://savannah.gnu.org/patch/download.php?item_id=3386&amp;item_file_id=3696






For detailed info, follow this link:
<http://savannah.gnu.org/patch/?func=detailitem&item_id=3386>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.gnu.org/







reply via email to

[Prev in Thread] Current Thread [Next in Thread]