[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnumach and gcc 4.x

From: Thomas Schwinge
Subject: Re: gnumach and gcc 4.x
Date: Thu, 2 Feb 2006 18:19:34 -0500
User-agent: Mutt/1.5.6+20040907i

On Mon, Oct 31, 2005 at 01:40:57AM +0100, Alfred M. Szmidt wrote:
> The following patch fixes the following problem (reported by Sergio):
> | I'm having trouble with the GNU Mach of your tarball, it stalls with
> | "panic: free_irq: bad irq number" just after the floppy disk
> | detection.  I've tried it on a P3 1000 Mhz laptop, on a AMD 700 Mhz
> | tower and on qemu with the same result in all cases (no IRQ sharing
> | problem).
> since (also from Sergio):
> | The problem seems to be a little bug (MAXIRQ value is 16, while
> | reg_IRQ array range is 0-15) in eata_dma and eata_pio scsi drivers
> | triggered by using gcc-4.0. Please try the attached patch, it works
> | for me.
> Here is the patch (once again from Sergio):
> [...]

I committed that patch.

2006-02-02  Sergio Lopez  <koro@sinrega.org>

        * linux/src/drivers/scsi/eata_pio.c (eata_pio_detect): Fix a
        off-by-one error when probing.
        * linux/src/drivers/scsi/eata_dma.c (eata_detect): Likewise.
        * linux/dev/drivers/scsi/eata_dma.c (eata_detect): Likewise.


Note that this problem also seems to persist in current versions of the
Linux-2.6 kernel.  Perhaps we should start thinking about backporting
fixes from GNU Mach to Linux-2.6.  ;-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]