[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #17319] /hurd/crash --suspend doesn't work

From: Ben Asselstine
Subject: [bug #17319] /hurd/crash --suspend doesn't work
Date: Tue, 8 Aug 2006 23:11:13 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20060731 Ubuntu/dapper-security Firefox/

Follow-up Comment #3, bug #17319 (project hurd):

I tried the patched crash server, and it didn't quite work as expected.

I retried Thomas' example:

thomas@leibniz:/var/tmp $ cat > crash.c
int main (void) { return *(int *) 0; }
thomas@leibniz:/var/tmp $ gcc crash.c
thomas@leibniz:/var/tmp $ ./a.out
Segmentation fault (core dumped)
thomas@leibniz:/var/tmp $ ls -l core
-rw------- 1 thomas root 16912384 Jun 15 20:43 core
thomas@leibniz:/var/tmp $ ls -l /servers/crash
lrwxr-xr-x 1 root root 13 Jun 15 20:42 /servers/crash -> crash-suspend
thomas@leibniz:/var/tmp $ showtrans /servers/crash-suspend
/hurd/crash --suspend

But I added:

$ fsysopts /servers/crash-suspend  --suspend --orphan-action=suspend

It didn't change the behaviour -- it still dumped core.  but,

$ fsysopts /servers/crash-suspend  --suspend --orphan-action=kill

did.  It suspended the task.

I then tried to attach to the crash server using gdb, but it said that the
pid didn't have any children.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]