bug-hurd
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug#407079: libtool: All GNU targets support -Wl, --version-script


From: Samuel Thibault
Subject: Re: Bug#407079: libtool: All GNU targets support -Wl, --version-script
Date: Tue, 23 Jan 2007 01:43:36 +0100
User-agent: Mutt/1.5.12-2006-07-14

Michael Banck, le Mon 22 Jan 2007 22:38:49 +0100, a ├ęcrit :
> Hopefully somebody can check that on CVS HEAD, do you expect big problems?

make check-local got all success except:

  8: preserve duplicate convenience deps             expected failure 
(duplicate_deps.at:60)
 12: F77 convenience archives                        skipped 
(convenience.at:104)
 13: FC convenience archives                         skipped 
(convenience.at:164)
 14: Java convenience archives                       skipped 
(convenience.at:224)
 18: shlibpath_overrides_runpath                     FAILED (shlibpath.at:61)
 45: build tree relpaths                             expected failure 
(deplibs-ident.at:61)

Attached is testsuite.log

The gdb backtrace of ./m is

#0  0x0000ed77 in __writev (fd=2, iov=0x101a600, niov=10)
    at ../sysdeps/mach/hurd/dl-sysdep.c:425
#1  0x0000c574 in _dl_debug_vdprintf (fd=2, tag_p=0, 
    fmt=0x101a560 "./m: symbol lookup error: ./m: undefined symbol: a\n", 
    arg=<value optimized out>) at dl-misc.c:267
#2  0x0000c97c in _dl_dprintf (fd=16896000, 
    fmt=0x101a560 "./m: symbol lookup error: ./m: undefined symbol: a\n")
    at dl-misc.c:303
#3  0x0000b79d in _dl_signal_error (errcode=0, objname=0x101b01b "./m", 
    occation=0x17de7 "symbol lookup error", 
    errstring=0x101ace0 "undefined symbol: a") at dl-error.c:106
#4  0x0000b85a in _dl_signal_cerror (errcode=0, objname=0x101b01b "./m", 
    occation=0x17de7 "symbol lookup error", 
    errstring=0x101ace0 "undefined symbol: a") at dl-error.c:136
#5  0x00008b3f in _dl_lookup_symbol_x (undef_name=0x804829a "a", 
    undef_map=0x1020948, ref=0x101adb0, symbol_scope=0x1020af4, version=0x0, 
    type_class=1, flags=1, skip_map=0x0) at dl-lookup.c:274
#6  0x0000b578 in fixup (l=0x1020948, reloc_offset=<value optimized out>)
    at dl-runtime.c:98
#7  0x0000b330 in _dl_runtime_resolve () at dl-runtime.c:136
#8  0x08048466 in main () at m.c:1

That may not be a bug in libtool, though.

For people who may want to debug, m is available in
gnubber:~youpi/libtool/tests/testsuite.dir/18/

Samuel




reply via email to

[Prev in Thread] Current Thread [Next in Thread]